diff mbox series

[bug#69658] gnu: Add go-github-com-whyrusleeping-go-sysinfo.

Message ID 06fefad7396d0e3eac5322eca446cb8a8d7649b2.1709936515.git.poptsov.artyom@gmail.com
State New
Headers show
Series [bug#69658] gnu: Add go-github-com-whyrusleeping-go-sysinfo. | expand

Commit Message

Artyom V. Poptsov March 8, 2024, 10:21 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-whyrusleeping-go-sysinfo): New
  variable.

Change-Id: I73cd3fa1ab3a73545121bb3a047795ca2850c0f7
---
 gnu/packages/golang-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 09346fd05f19da3846635e1a0f1c844050d59f26

Comments

Sharlatan Hellseher March 11, 2024, 8:11 p.m. UTC | #1
Hi,

Thank you for the patch.

I know it's hard with some golang module documentation but try to
 add a little bit more info in package description than it's in synopsis.

I started reviewing aggregated patches related to golang.

Thanks,
Oleg
Sharlatan Hellseher March 17, 2024, 12:14 a.m. UTC | #2
Hi,

I've adjusted descripton and checked the project status
https://github.com/whyrusleeping/go-sysinfo/issues/3

Pushed as 85c816c7ad0c9486fe71c72a5c15d6e625da7458 to master

--
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b3db6e379..f46edd3768 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1685,6 +1685,28 @@  (define-public go-github-com-vividcortex-ewma
 weighted moving averages}.")
     (license license:expat)))
 
+(define-public go-github-com-whyrusleeping-go-sysinfo
+  (package
+    (name "go-github-com-whyrusleeping-go-sysinfo")
+    (version "0.0.0-20190219211824-4a357d4b90b1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/whyrusleeping/go-sysinfo")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0s6yjp9incc579wbbga33vq0hcanv8j2xh9l90ya0r4fihz39jiq"))))
+    (build-system go-build-system)
+    (inputs (list go-github-com-dustin-go-humanize))
+    (arguments
+     '(#:import-path "github.com/whyrusleeping/go-sysinfo"))
+    (home-page "https://github.com/whyrusleeping/go-sysinfo")
+    (synopsis "Package to extract system information")
+    (description "Package to extract system information.")
+    (license license:expat)))
+
 (define-public go-go-uber-org-automaxprocs
   (package
     (name "go-go-uber-org-automaxprocs")