diff mbox series

[bug#58620] Update blur my shell

Message ID 06cSobEp775u_dSNlI451HkpvLL7bRRRNW7WSQ5PJCnmCeFUwoeRujzdP3KeHLhQk8rp1LICwwM9Qxwlf1KcMw0mkn-54M-G-geOyYeNldE=@proton.me
State Accepted
Headers show
Series [bug#58620] Update blur my shell | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Charles Oct. 22, 2022, 4:33 a.m. UTC
Thank you for the great review, Liliana. Using the install plan makes this so much better. I think I have addressed all your feedback. Updated patch attatched.

------- Original Message -------
On Thursday, October 20th, 2022 at 8:01 AM, Liliana Marie Prikler <liliana.prikler@ist.tugraz.at> wrote:


> Am Mittwoch, dem 19.10.2022 um 04:25 +0000 schrieb Charles:
> 
> > [PATCH] gnu: gnome-shell-extensions: Update blur my shell to version
> > 44.
> 
> Should be: "gnu: update gnome-shell-extension-blur-my-shell to 44".
> 
> > * gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell)
> > Update version and hash. Add a phase to move the contents of the src
> > and resources directories to project root so they get installed
> > properly.
> 
> Break lines between changes and make clear what's changed. Use
> indicators such as [#:phases].
> 
> > ---
> > gnu/packages/gnome-xyz.scm | 31 ++++++++++++++++++++++---------
> > 1 file changed, 22 insertions(+), 9 deletions(-)
> > 
> > diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
> > index 68166978a1..89bb9c9d7b 100644
> > --- a/gnu/packages/gnome-xyz.scm
> > +++ b/gnu/packages/gnome-xyz.scm
> > @@ -996,7 +996,7 @@ (define-public gnome-shell-extension-burn-my-
> > windows
> > (define-public gnome-shell-extension-blur-my-shell
> > (package
> > (name "gnome-shell-extension-blur-my-shell")
> > - (version "29")
> > + (version "44")
> > (source
> > (origin
> > (method git-fetch)
> > @@ -1006,9 +1006,7 @@ (define-public gnome-shell-extension-blur-my-
> > shell
> > (file-name (git-file-name name version))
> > (sha256
> > (base32
> > - "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
> > - (snippet
> > - '(begin (delete-file "src/schemas/gschemas.compiled")))))
> > + "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
> 
> Why is the snippet removed?
> 
> > (build-system copy-build-system)
> > (arguments
> > `(#:install-plan
> > @@ -1016,15 +1014,30 @@ (define-public gnome-shell-extension-blur-my-
> > shell
> > "share/gnome-shell/extensions/"
> > "blur-my-shell@aunetx")
> > #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$"
> > "\\.png$"
> > - "\\.xml$" "\\.compiled$")))
> > + "\\.svg$" "\\.xml$" "\\.compiled$")))
> 
> Note the addition of "\\.svg$" in the ChangeLog.
> 
> > #:phases
> > (modify-phases %standard-phases
> > - (add-after 'unpack 'cd-src
> > - (lambda _ (chdir "src")))
> > - (add-before 'install 'compile-schemas
> > + (add-after 'unpack 'compile-schemas
> > (lambda _
> > (with-directory-excursion "schemas"
> > - (invoke "glib-compile-schemas" ".")))))))
> > + (invoke "glib-compile-schemas" "."))))
> > + (add-before 'install 'unpack-src
> > + (lambda _
> > + (use-modules (ice-9 ftw))
> > + (define (explode-dir dir)
> > + (for-each
> > + (lambda (file)
> > + (let ((full-file-name
> > + (string-append (getcwd) "/" dir "/" file)))
> > + (rename-file
> > + full-file-name
> > + (string-append (getcwd) "/" file))))
> > + (filter (lambda (file)
> > + (not (or (string=? file ".")
> > + (string=? file ".."))))
> > + (scandir (string-append (getcwd) "/"
> > dir)))))
> > + (explode-dir "src")
> > + (explode-dir "resources"))))))
> 
> Adjust #:install-plan instead.
> 
> > (native-inputs
> > (list (list glib "bin"))) ; for glib-compile-schemas
> > (home-page "https://github.com/aunetx/blur-my-shell")
> > --
> 
> Cheers

Comments

Liliana Marie Prikler Oct. 22, 2022, 9:07 a.m. UTC | #1
Am Samstag, dem 22.10.2022 um 04:33 +0000 schrieb Charles:

> Thank you for the great review, Liliana. Using the install plan makes
> this so much better. I think I have addressed all your feedback.
> Updated patch attatched.
Pushed with the following changes:

> +     '(#:install-plan
> +       (let ((install-location
> +              (string-append
> +               "share/gnome-shell/extensions/"
> +               "blur-my-shell@aunetx")))
> +         `(("src/" ,install-location)
> +           ("resources/" ,install-location
> +            #:include-regexp ("\\.svg$" "\\.ui"))
> +           ("." ,install-location
> +            #:exclude-regexp ("src/" "resources/")
> +            #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$"
> "\\.png$"
> +                              "\\.xml$" "\\.compiled$"))))
Used a shorter name for install-location for the sake of conciseness.

> -     (list (list glib "bin"))) ; for glib-compile-schemas
> +     (list (list "glib:bin" glib "bin"))) ; for glib-compile-schemas
Dropped this, because the linter warning is a false positive.

I also rewrote the commit message to fall in line with the others.

Cheers
diff mbox series

Patch

From 6181077fa41eac60929533e16716ac857d6f5576 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Tue, 18 Oct 2022 23:04:24 -0500
Subject: [PATCH] gnu: Update gnome-shell-extension-blur-my-shell to 44.

* gnu/packages/gnome-xyz.scm (gnome-shell-extension-blur-my-shell): Update
version and hash.
Remove snippet to delete compiled schemas because upstream stopped keeping
them in version control.
Install files from the resources and src directories into the root directory in [#:install-plan].
Add identifier glib:bin to satisfy guix lint.
---
 gnu/packages/gnome-xyz.scm | 32 +++++++++++++++++---------------
 1 file changed, 17 insertions(+), 15 deletions(-)

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 68166978a1..fbf110159f 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -996,7 +996,7 @@  (define-public gnome-shell-extension-burn-my-windows
 (define-public gnome-shell-extension-blur-my-shell
   (package
     (name "gnome-shell-extension-blur-my-shell")
-    (version "29")
+    (version "44")
     (source
      (origin
        (method git-fetch)
@@ -1006,27 +1006,29 @@  (define-public gnome-shell-extension-blur-my-shell
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "13x7zgaj3dz7lypdv1bgmpmh0f2w53q567zxmhmqimi1gy5mjrvk"))
-       (snippet
-        '(begin (delete-file "src/schemas/gschemas.compiled")))))
+         "0h7yfvrrg5r821mzrp42c09jws06mw6v9avvkfykqj8n8qnslmyx"))))
     (build-system copy-build-system)
     (arguments
-     `(#:install-plan
-       '(("." ,(string-append
-                "share/gnome-shell/extensions/"
-                "blur-my-shell@aunetx")
-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$")))
+     '(#:install-plan
+       (let ((install-location
+              (string-append
+               "share/gnome-shell/extensions/"
+               "blur-my-shell@aunetx")))
+         `(("src/" ,install-location)
+           ("resources/" ,install-location
+            #:include-regexp ("\\.svg$" "\\.ui"))
+           ("." ,install-location
+            #:exclude-regexp ("src/" "resources/")
+            #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                              "\\.xml$" "\\.compiled$"))))
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'cd-src
-           (lambda _ (chdir "src")))
-         (add-before 'install 'compile-schemas
+         (add-after 'unpack 'compile-schemas
            (lambda _
              (with-directory-excursion "schemas"
                (invoke "glib-compile-schemas" ".")))))))
     (native-inputs
-     (list (list glib "bin"))) ; for glib-compile-schemas
+     (list (list "glib:bin" glib "bin"))) ; for glib-compile-schemas
     (home-page "https://github.com/aunetx/blur-my-shell")
     (synopsis "Blurs different parts of the GNOME Shell")
     (description "Blur My Shell adds a blur look to different parts of the
-- 
2.38.0