diff mbox series

[bug#70950,v2] gnu: nss/fixed: Hasten test suite.

Message ID 069d9c1216195e1c4a6dbe2f826d1893bc3dce9a.1716394161.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#70950,v2] gnu: nss/fixed: Hasten test suite. | expand

Commit Message

Maxim Cournoyer May 22, 2024, 4:09 p.m. UTC
This causes the test suite to run in about in nearly a third of the original
time (from 145 min to 52 minutes on a particular machine).

* gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
environment variable to 'standard'.

Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
---

(no changes since v1)

 gnu/packages/nss.scm | 5 +++++
 1 file changed, 5 insertions(+)


base-commit: b462cff5ee582d09a0a6b656bea3b1e77c1f57a5

Comments

Maxim Cournoyer May 30, 2024, 2:05 a.m. UTC | #1
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> This causes the test suite to run in about in nearly a third of the original
> time (from 145 min to 52 minutes on a particular machine).
>
> * gnu/packages/nss.scm (nss/fixed) [phases] {check}: Set NSS_CYCLES
> environment variable to 'standard'.
>
> Change-Id: I5dab1ed16b302af2276b0f075a790f6193edbe95
> ---
>
> (no changes since v1)
>
>  gnu/packages/nss.scm | 5 +++++
>  1 file changed, 5 insertions(+)
>
> diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
> index 80bf627583..8fb8a2fc99 100644
> --- a/gnu/packages/nss.scm
> +++ b/gnu/packages/nss.scm
> @@ -288,6 +288,11 @@ (define-public nss/fixed
>                           (substitute* "nss/tests/dbtests/dbtests.sh"
>                             ((" -lt 5") " -lt 50"))
>  
> +                         ;; Since the test suite is very lengthy, run the test
> +                         ;; suite once, not thrice as done by default, by
> +                         ;; selecting only the 'standard' cycle.
> +                         (setenv "NSS_CYCLES" "standard")
> +
>                           ;; The "PayPalEE.cert" certificate expires every six months,
>                           ;; leading to test failures:
>                           ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To
>
> base-commit: b462cff5ee582d09a0a6b656bea3b1e77c1f57a5

Merged with c9e3806ec1686f348f2ac5d88cf65daed74a721b.
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 80bf627583..8fb8a2fc99 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -288,6 +288,11 @@  (define-public nss/fixed
                          (substitute* "nss/tests/dbtests/dbtests.sh"
                            ((" -lt 5") " -lt 50"))
 
+                         ;; Since the test suite is very lengthy, run the test
+                         ;; suite once, not thrice as done by default, by
+                         ;; selecting only the 'standard' cycle.
+                         (setenv "NSS_CYCLES" "standard")
+
                          ;; The "PayPalEE.cert" certificate expires every six months,
                          ;; leading to test failures:
                          ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To