[bug#76513,rust-team,23/77] gnu: Add rust-codex-0.1.

Message ID 069371bc8fcd2fa8f370ae217ead0ad1e2f95055.1740340805.git.wongandj@icloud.com
State New
Headers
Series Add module (gnu packages typst) and packages |

Commit Message

Andrew Wong Feb. 23, 2025, 8:21 p.m. UTC
  * gnu/packages/crates-io.scm (rust-codex-0.1): New variable.

Change-Id: Ic788a5ad752a9359aefe9b27498c542c129a1925
---
 gnu/packages/crates-io.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
  

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 79e0b475a8..f86da6441f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13759,6 +13759,26 @@  (define-public rust-codespan-reporting-0.11
 diagnostics easy and relatively painless for everyone!")
     (license license:asl2.0)))
 
+(define-public rust-codex-0.1
+  (package
+    (name "rust-codex")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "codex" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0dj0hqw3wk5p3k77zi1sczds00d6mdwhwdb4w7jh1drqxsh2fkbj"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t))
+    (home-page "https://github.com/typst/codex")
+    (synopsis "Human-friendly notation for Unicode symbols")
+    (description
+     "This package provides Human-friendly notation for Unicode symbols.")
+    (license license:asl2.0)))
+
 (define-public rust-codspeed-2
   (package
     (name "rust-codspeed")