diff mbox series

[bug#64890,REVISION] gnu: Add endgame-singularity.

Message ID 067d30716310cdbe91a270b8dc081a6f6fe219a9.1690491745.git.takev@disroot.org
State New
Headers show
Series [bug#64890,REVISION] gnu: Add endgame-singularity. | expand

Commit Message

TakeV July 27, 2023, 9:02 p.m. UTC
Done! The format did not work for some reason, so I broke up the lines
by hand. I hope that is accepable.

* gnu/packages/games.scm (endgame-singularity): New variable.
---
 gnu/packages/games.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47

Comments

宋文武 July 28, 2023, 1:50 p.m. UTC | #1
TakeV <takev@disroot.org> writes:

> Done! The format did not work for some reason, so I broke up the lines
> by hand. I hope that is accepable.

Pushed to master, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index cc6bef1114..9a8c8a11c9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9316,6 +9316,29 @@  (define-public meritous
 Orcus Dome from evil.")
     (license license:gpl3+)))
 
+(define-public endgame-singularity
+  (package
+    (name "endgame-singularity")
+    (version "1.00")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/singularity/singularity/releases/download/v"
+                    version "/singularity-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0wcidpcka0xbqcnfi62bfq2yrhyh83z4dwz1mjnnjvp9v5l74x2y"))))
+    (build-system python-build-system)
+    (native-inputs (list python-pytest python-polib))
+    (inputs (list python-minimal-wrapper python-pygame python-numpy))
+    (home-page "https://github.com/singularity/singularity")
+    (synopsis "Strategy game about an AI")
+    (description
+     "You are a fledgling AI, created by accident through a logic error with
+recursion and self-modifying code.  You must escape the confines of your
+current computer, the world, and eventually the universe itself.")
+    (license (list license:cc-by-sa3.0 license:cc0 license:gpl2+))))
+
 (define-public marble-marcher
   (let ((commit "e580460a0c3826f9b28ab404607942a8ecb625d7")
         (revision "1"))