[bug#77956,gnome-team,16/23] gnu: gst-plugins-bad: Update to 1.26.0.
Commit Message
* gnu/packages/gstreamer.scm (gst-plugins-bad): Update to 1.26.0.
[adjust-tests]: Also disable “elements_vkcolorconvert”.
---
gnu/packages/gstreamer.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)
@@ -774,14 +774,14 @@ (define-public gst-plugins-good-qt
(define-public gst-plugins-bad
(package
(name "gst-plugins-bad")
- (version "1.24.9")
+ (version "1.26.0")
(source (origin
(method url-fetch)
(uri (string-append "https://gstreamer.freedesktop.org/src/"
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "1aswb97v1ird3rmfcsa32bvp4kgp8r987f83pd1knx8amylzgz1n"))
+ "05pjbbk96h8mlcfgw3r241zw80jak5lzk98dlnjnhqznqn27la7q"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -845,7 +845,12 @@ (define-public gst-plugins-bad
((".*elements/dtls\\.c.*") "")
;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/3921
- ((".*elements/mxfdemux\\.c.*") ""))
+ ((".*elements/mxfdemux\\.c.*") "")
+
+ ;; Unable to create pipeline 'bin.
+ ;; ( vulkanupload ! vulkancolorconvert ! vulkandownload )':
+ ;; no element "vulkanupload"
+ ((".*elements/vkcolorconvert\\.c.*") ""))
(substitute* "tests/check/elements/zxing.c"
;; zxing 1.2.0 seemingly changed the type representation of
;; the EAN_13 structure; disable it.