diff mbox series

[bug#64700] gnu: Add python-scm-sr-ht.

Message ID 05ab557548dec022ab277bdaa0301a7299a22b2f.1689684539.git.rekado@elephly.net
State New
Headers show
Series [bug#64700] gnu: Add python-scm-sr-ht. | expand

Commit Message

Ricardo Wurmus July 18, 2023, 12:48 p.m. UTC
* gnu/packages/sourcehut.scm (python-scm-sr-ht): New variable.
---
 gnu/packages/sourcehut.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: 3a3752400d7a70a295a27b66f29457aeeaa2cf27
prerequisite-patch-id: 80d1fed622f0306a9ff2f0ca55ed10a24b7f283a
diff mbox series

Patch

diff --git a/gnu/packages/sourcehut.scm b/gnu/packages/sourcehut.scm
index 382c357d78..9222101b84 100644
--- a/gnu/packages/sourcehut.scm
+++ b/gnu/packages/sourcehut.scm
@@ -79,3 +79,34 @@  (define-public python-core-sr-ht
     (description
      "This package contains code shared among all sr.ht projects.")
     (license license:bsd-3)))
+
+(define-public python-scm-sr-ht
+  (package
+    (name "python-scm-sr-ht")
+    (version "0.22.23")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~sircmpwn/scm.sr.ht")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1p1nlwqfqfb89nky8sp4jh4vjnh8fm2mdx8inziqs3898qw1v7yk"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:tests? #false                   ;there are none
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'set-version
+            (lambda _ (setenv "PKGVER" #$version))))))
+    (propagated-inputs
+     (list python-core-sr-ht))
+    (home-page "https://git.sr.ht/~sircmpwn/scm.sr.ht")
+    (synopsis "Shared support code for sr.ht source control services")
+    (description
+     "This package provides shared support code for sr.ht source control
+services.")
+    (license license:agpl3)))