diff mbox series

[bug#52174,v2,2/6] gnu: add conmon

Message ID 058f226cf4e0b5fdb6642ff4b9d20e28b5312781.1639889841.git.mail@timmydouglas.com
State Accepted
Headers show
Series [bug#52174,v2,1/6] gnu: add crun | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Timmy Douglas Dec. 19, 2021, 4:58 a.m. UTC
* gnu/packages/containers.scm: add conmon
---
 gnu/packages/containers.scm | 42 +++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

Comments

Timmy Douglas Dec. 21, 2021, 10:42 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> writes:

> Timmy Douglas <mail@timmydouglas.com> skribis:
>
>> * gnu/packages/containers.scm: add conmon
>
> [...]
>
>> +    (source
>> +     (origin
>> +       (method git-fetch)
>> +       (uri (git-reference
>> +             (url "https://github.com/containers/conmon")
>> +             (commit (string-append "v" version))))
>> +       (sha256
>> +        (base32 "1sxpbm01g4xak4kqwvk45gmzr6n9bjzlfp1j85wyz8rj2hg2x4rm"))
>> +       (file-name (git-file-name name version))))
>> +
>> +    (build-system gnu-build-system)
>
> Nitpick: you can remove the empty line.

ok. I think guix lint outputted that way or maybe I already had it like that?

>> +    (arguments
>> +     `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
>> +                          (string-append "PREFIX=" %output))
>> +                    #:tests? #f ; currently broken as go tries to use network
>
> Indentation is off.

emacs really likes to indent it like that. I wonder if I'm missing
something in my setup.


I'll take a look at just skipping network tests rather than avoiding
them altogether.
Ludovic Courtès Dec. 24, 2021, 3:25 p.m. UTC | #2
Timmy Douglas <mail@timmydouglas.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Timmy Douglas <mail@timmydouglas.com> skribis:

[...]

>>> +    (arguments
>>> +     `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
>>> +                          (string-append "PREFIX=" %output))
>>> +                    #:tests? #f ; currently broken as go tries to use network
>>
>> Indentation is off.
>
> emacs really likes to indent it like that. I wonder if I'm missing
> something in my setup.

I does it right for me, but I forgot if it’s the default or if it’s
thanks to Emacs-Guix or something else.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 7ffe6e95d0..d4f9d742db 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -85,3 +85,45 @@  (define-public crun
       (description
        "crun is a fast and low-memory footprint OCI Container Runtime fully written in C.")
       (license license:gpl2+))))
+
+(define-public conmon
+  (package
+    (name "conmon")
+    (version "2.0.30")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/containers/conmon")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "1sxpbm01g4xak4kqwvk45gmzr6n9bjzlfp1j85wyz8rj2hg2x4rm"))
+       (file-name (git-file-name name version))))
+
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list ,(string-append "CC=" (cc-for-target))
+                          (string-append "PREFIX=" %output))
+                    #:tests? #f ; currently broken as go tries to use network
+                    #:phases (modify-phases %standard-phases
+                               (delete 'configure)
+                               (add-after 'unpack 'set-env
+                                 (lambda* (#:key inputs #:allow-other-keys)
+                                   ;; when running go, things fail because
+                                   ;; HOME=/homeless-shelter.
+                                   (setenv "HOME" "/tmp")))
+                               (replace 'check
+                                 (lambda* (#:key tests? #:allow-other-keys)
+                                   (when tests?
+                                     (invoke "make" "test")))))))
+    (inputs
+     (list glib glibc libseccomp crun))
+    (native-inputs
+     (list git go pkg-config))
+    (home-page "https://github.com/containers/conmon")
+    (synopsis "Monitoring and communication tool between container manager and OCI runtime")
+    (description
+     "Conmon is a monitoring program and communication tool between a container
+manager (like Podman or CRI-O) and an OCI runtime (like runc or crun) for a
+single container.")
+    (license license:asl2.0)))