diff mbox series

[bug#73021,v2] gnu: Add gnudos.

Message ID 055fc8afbad682962b314f4f3a6e88b4ff755195.1725429648.git.atai@atai.org
State New
Headers show
Series [bug#73021,v2] gnu: Add gnudos. | expand

Commit Message

Andy Tai Sept. 4, 2024, 6:01 a.m. UTC
* gnu/packages/mc.scm (gnudos): New variable.

Change-Id: I03a101be81bba3e4fdf8e11a7b4a799b92f86ad0
---
 gnu/packages/mc.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
prerequisite-patch-id: a15c31b7d62dad1884467d4668ea9e851a61603e
diff mbox series

Patch

diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index dc909ed7e1..2a716ce782 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -120,3 +120,26 @@  (define-public mc
 FTP or FISH.  It also includes a powerful text editor for opening text
 files.")
     (license gpl3+)))
+
+
+(define-public gnudos
+  (package
+    (name "gnudos")
+    (version "2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://gnu/gnudos/gnudos-" version ".tar.gz"))
+       (sha256
+        (base32 "06n4n6j7w6f54akmqqmsrbxv5rj6xairc6yskm33ag2ar7w8hz48"))))
+    (build-system gnu-build-system)
+    (inputs (list ncurses))
+    (home-page "https://www.gnu.org/software/gnudos/")
+    (synopsis "MS-DOS-like file manager, editor, and other tools")
+    (description
+     "GnuDOS is a set of programs designed to help new users of the GNU
+system in growing accustomed to the system, particularly users who might be
+coming from a DOS background.  It consists of a file manager, a text editor
+and a form designer for the console as well as a core library for building
+similar utilities.")
+    (license gpl3+)))