diff mbox series

[bug#40468,3/3] gnu: Add shiru-lv2.

Message ID 053db596207697e4b7d32b55a965b2ba88beca75.camel@zrythm.org
State Accepted
Headers show
Series [bug#40466,1/3] gnu: dragonfly-reverb: Use regex to install binaries. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou April 6, 2020, 2:16 p.m. UTC
Hi,

This patch adds shiru plugins (unofficial LV2 port). No tag is
available yet and I'm using the date instead of a commit in the version
so new versions can be detected easily.

Thanks,
Alex
diff mbox series

Patch

From d4bf736c099c526f0b77b3bab0f8debf149ce5be Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Mon, 6 Apr 2020 15:10:06 +0100
Subject: [PATCH 3/3] gnu: Add shiru-lv2.

* gnu/packages/music.scm (shiru-lv2): New variable.
---
 gnu/packages/music.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index e2a3d84572..85e5fa20cb 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5387,3 +5387,33 @@  filtered, pitch shifted and ultimately disintegrated.  This is an unofficial
 port of the Regrader plugin created by Igorski.  It is available as an LV2
 plugin and a standalone JACK application.")
     (license license:expat)))
+
+(define-public shiru-lv2
+  (package/inherit dragonfly-reverb
+    (name "shiru-lv2")
+    (version "0.0.0-20200406")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/shiru-plugins.git")
+               (commit "08853f99140012234649e67e5647906fda74f6cc")
+               ;; Bundles a specific commit of the DISTRHO plugin framework.
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+          (base32
+            "00rf6im3rhg98h60sgl1r2s37za5vr5h14pybwi07h8zbc8mi6fm"))))
+    (inputs
+      `(("cairo", cairo)
+        ("glu", glu)
+        ("jack", jack-1)
+        ("lv2", lv2)
+        ("mesa", mesa)
+        ("pango", pango)))
+    (synopsis "Audio plugin collection")
+    (description "Shiru plugins is a collection of audio plugins created
+by Shiru, ported to LV2 by the Linux MAO project using the DISTRHO plugin
+framework.")
+    (home-page "http://shiru.untergrund.net/software.shtml")
+    (license license:wtfpl2)))
-- 
2.26.0