[bug#76259,3/3] gnu: Add python-pandamesh.
Commit Message
* gnu/packages/geo.scm (python-pandamesh): New variable.
Change-Id: I084c772f859cde3be4d4b611cba6b5420067bbe8
---
gnu/packages/geo.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)
@@ -1091,6 +1091,41 @@ (define-public python-geopandas
require a spatial database such as PostGIS.")
(license license:bsd-3)))
+(define-public python-pandamesh
+ (package
+ (name "python-pandamesh")
+ (version "0.2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Deltares/pandamesh")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gnrxw8zxcdkkqzw08lrmnz946bp507r9zn1djhaxxqjs09yzmqp"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; tests requiring network disabled
+ (invoke "pytest" "-v" "--ignore=tests/test_data.py")))))))
+ (propagated-inputs (list gmsh
+ python-geopandas
+ python-matplotlib
+ python-pooch
+ python-shapely
+ python-triangle
+ python-xarray))
+ (native-inputs (list python-hatchling python-pytest))
+ (home-page "https://deltares.github.io/pandamesh/")
+ (synopsis "From geodataframe to mesh")
+ (description "From geodataframe to mesh.")
+ (license license:expat)))
+
(define-public python-overpass
(package
(name "python-overpass")