[bug#76259,3/3] gnu: Add python-pandamesh.

Message ID 048a91bda30167d10ed31643fcf0ee6bfc96a1d1.1739439090.git.lars.bilke@ufz.de
State New
Headers
Series Add python-triangle, python-pandamesh and update gmsh to 4.13.1. |

Commit Message

Lars Bilke Feb. 13, 2025, 9:38 a.m. UTC
  * gnu/packages/geo.scm (python-pandamesh): New variable.

Change-Id: I084c772f859cde3be4d4b611cba6b5420067bbe8
---
 gnu/packages/geo.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)
  

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index d7cef57cde..0070b8a3c1 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -1091,6 +1091,41 @@  (define-public python-geopandas
 require a spatial database such as PostGIS.")
     (license license:bsd-3)))
 
+(define-public python-pandamesh
+  (package
+    (name "python-pandamesh")
+    (version "0.2.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Deltares/pandamesh")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gnrxw8zxcdkkqzw08lrmnz946bp507r9zn1djhaxxqjs09yzmqp"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         ;; tests requiring network disabled
+                         (invoke "pytest" "-v" "--ignore=tests/test_data.py")))))))
+    (propagated-inputs (list gmsh
+                             python-geopandas
+                             python-matplotlib
+                             python-pooch
+                             python-shapely
+                             python-triangle
+                             python-xarray))
+    (native-inputs (list python-hatchling python-pytest))
+    (home-page "https://deltares.github.io/pandamesh/")
+    (synopsis "From geodataframe to mesh")
+    (description "From geodataframe to mesh.")
+    (license license:expat)))
+
 (define-public python-overpass
   (package
     (name "python-overpass")