diff mbox series

[bug#68150,v2,3/8] gnu: libreoffice: Actually use glib-or-gtk-build-system.

Message ID 048211ca5d3fca6a7d86973ddf7bfb8dca426649.1728234031.git.~@wolfsden.cz
State New
Headers show
Series [bug#68150,v2,1/8] build: glib-or-gtk: Export %glib-or-gtk-build-system-default-modules. | expand

Commit Message

Tomas Volf Oct. 6, 2024, 5 p.m. UTC
The #:modules argument was based on %glib-or-gtk-build-system-modules, which,
despite the name, should go into #:imported-modules.  When put into #:modules,
it leads to following warning:

    WARNING: (guile-user): `%standard-phases' imported from both (guix build glib-or-gtk-build-system) and (guix build gnu-build-system)

Due to the definition of %glib-or-gtk-build-system-modules

    `((guix build glib-or-gtk-build-system)
      ,@%gnu-build-system-modules)

It results in %standard-phases from gnu-build-system being used, effectively
turning glib-or-gtk-build-system with #:modules set to
%glib-or-gtk-build-system-modules into gnu-build-system.

The solution is to use the (now) exported default value of
 #:modules (%glib-or-gtk-build-system-default-modules) as a base of the
 #:modules.

* gnu/packages/libreoffice.scm (libreoffice)[arguments]<#:modules>: Use
%glib-or-gtk-build-system-default-modules instead of
%glib-or-gtk-build-system-modules.

Change-Id: I5304d9993af7d5f1187c6276e72a269aa60f5666
---
Rebase on latest master.

 gnu/packages/libreoffice.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

--
2.46.0
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index ed8dfd432b..2acbddaa3b 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -908,7 +908,7 @@  (define-public libreoffice
                            ,@%glib-or-gtk-build-system-modules)
       #:modules `(((guix build python-build-system) #:select (python-version))
                   (ice-9 textual-ports)
-                  ,@%glib-or-gtk-build-system-modules)
+                  ,@%glib-or-gtk-build-system-default-modules)
       #:tests? #f                       ; Building the tests already fails.
       #:phases
       #~(modify-phases %standard-phases