* gnu/packages/tls.scm (mbedtls-apache): Rename package to "mbedtls".
Rename variable to…
(mbedtls-lts): …this.
(mbedtls-apache): Define as deprecated by mbedtls-lts.
(mbedtls-for-hiawatha): Adjust accordingly.
* doc/guix.texi: Likewise.
* gnu/packages/emulators.scm (dolphin-emu,retroarch)[inputs]: Likewise.
* gnu/packages/game-development.scm (godot-lts,godot)[inputs]: Likewise.
* gnu/packages/hardware.scm (hueplusplus,openrgb)[inputs]: Likewise.
* gnu/packages/haxe.scm (neko,haxe,hashlink)[inputs]: Likewise.
* gnu/packages/irc.scm (inspircd)[inputs]: Likewise.
* gnu/packages/julia-jll.scm (julia-mbedtls-jll)[arguments]<#:phases>,[inputs]:
Likewise.
* gnu/packages/julia.scm (julia)[arguments]<#:phases>,[inputs]: Likewise.
* gnu/packages/linphone.scm (bctoolbox)[inputs]: Likewise.
* gnu/packages/linux.scm (dislocker)[inputs]: Likewise.
* gnu/packages/networking.scm (nng)[inputs]: Likewise.
* gnu/packages/search.scm (dataparksearch)[inputs]: Likewise.
* gnu/packages/video.scm (obs)[inputs]: Likewise.
* gnu/packages/web.scm (hiawatha)[arguments]<#:phases>: Likewise.
Change-Id: I0c58b3cd0bcf6e44e7b16a69f6d2739aa3c1545b
---
doc/guix.texi | 2 +-
gnu/packages/emulators.scm | 4 ++--
gnu/packages/game-development.scm | 4 ++--
gnu/packages/hardware.scm | 4 ++--
gnu/packages/haxe.scm | 6 +++---
gnu/packages/irc.scm | 2 +-
gnu/packages/julia-jll.scm | 4 ++--
gnu/packages/julia.scm | 12 ++++++------
gnu/packages/linphone.scm | 2 +-
gnu/packages/linux.scm | 2 +-
gnu/packages/networking.scm | 2 +-
gnu/packages/search.scm | 2 +-
gnu/packages/tls.scm | 11 +++++++----
gnu/packages/video.scm | 2 +-
gnu/packages/web.scm | 2 +-
15 files changed, 32 insertions(+), 29 deletions(-)
@@ -9850,7 +9850,7 @@ Build Systems
(("generate_wrapper_header.*")
(string-append
"generate_wrapper_header(\"MbedTLS\", \""
- (assoc-ref inputs "mbedtls-apache") "\")\n"))))
+ (assoc-ref inputs "mbedtls") "\")\n"))))
;; There's a Julia file for each platform, override them all.
(find-files "src/wrappers/" "\\.jl$"))))
@end lisp
@@ -351,7 +351,7 @@ (define-public dolphin-emu
libxi
libxrandr
lzo
- mbedtls-apache
+ mbedtls-lts
mesa
miniupnpc
openal
@@ -1490,7 +1490,7 @@ (define-public retroarch
libxml2
libxrandr
libxv
- mbedtls-apache
+ mbedtls-lts
mesa
openal
openssl
@@ -2038,7 +2038,7 @@ (define-public godot-lts
libxi
libxinerama
libxrandr
- mbedtls-apache
+ mbedtls-lts
mesa
opusfile
pcre2
@@ -2280,7 +2280,7 @@ (define-public godot
libxinerama
libxkbcommon
libxrandr
- mbedtls-apache
+ mbedtls-lts
mesa
openxr
opusfile
@@ -703,7 +703,7 @@ (define-public hueplusplus
(arguments
`(#:tests? #f)) ;; Tests require Google's gtest and gmock
(inputs
- (list mbedtls-apache))
+ (list mbedtls-lts))
(synopsis "C++ library to control Philips Hue lights")
(description "Hueplusplus is a library for controlling Philips Hue lights.
Features:
@@ -1112,7 +1112,7 @@ (define-public openrgb
hueplusplus
nlohmann-json
libusb
- mbedtls-apache
+ mbedtls-lts
qtbase-5))
(native-inputs
(list pkg-config
@@ -78,7 +78,7 @@ (define-public neko
apr-util
gtk+-2
libgc
- mbedtls-apache
+ mbedtls-lts
(list mariadb "dev")
(list mariadb "lib")
openssl
@@ -171,7 +171,7 @@ (define-public haxe
(lambda _
(invoke "make" "install"))))))
(inputs (list libuv
- mbedtls-apache
+ mbedtls-lts
neko
ocaml-extlib
ocaml-luv
@@ -255,7 +255,7 @@ (define-public hashlink
libpng
libuv
libvorbis
- mbedtls-apache
+ mbedtls-lts
mikktspace
minimp3
openal
@@ -912,7 +912,7 @@ (define-public inspircd
(list argon2
gnutls
libmaxminddb
- mbedtls-apache
+ mbedtls-lts
(list mariadb "dev")
openldap
openssl
@@ -1399,11 +1399,11 @@ (define-public julia-mbedtls-jll
(("generate_wrapper_header.*")
(string-append
"generate_wrapper_header(\"MbedTLS\", \""
- (assoc-ref inputs "mbedtls-apache") "\")\n"))))
+ (assoc-ref inputs "mbedtls") "\")\n"))))
;; There's a Julia file for each platform, override them all
(find-files "src/wrappers/" "\\.jl$"))
#t)))))
- (inputs (list mbedtls-apache))
+ (inputs (list mbedtls-lts))
(propagated-inputs (list julia-jllwrappers))
(home-page "https://github.com/JuliaBinaryWrappers/MbedTLS_jll.jl")
(synopsis "Apache's mbed TLS binary wrappers")
@@ -186,7 +186,7 @@ (define-public julia
"gmp" "lapack"
"libssh2" "libnghttp2" "libgit2"
"libblastrampoline"
- "mbedtls-apache" "mpfr"
+ "mbedtls" "mpfr"
"openblas" "openlibm" "pcre2"
"suitesparse" "gfortran:lib"))
":"))))
@@ -263,9 +263,9 @@ (define-public julia
(substitute* (jlpath "MPFR")
(((from "libmpfr")) (to "mpfr" "libmpfr")))
(substitute* (jlpath "MbedTLS")
- (((from "libmbedcrypto")) (to "mbedtls-apache" "libmbedcrypto"))
- (((from "libmbedtls")) (to "mbedtls-apache" "libmbedtls"))
- (((from "libmbedx509")) (to "mbedtls-apache" "libmbedx509")))
+ (((from "libmbedcrypto")) (to "mbedtls" "libmbedcrypto"))
+ (((from "libmbedtls")) (to "mbedtls" "libmbedtls"))
+ (((from "libmbedx509")) (to "mbedtls" "libmbedx509")))
(substitute* (jlpath "nghttp2")
(((from "libnghttp2")) (to "libnghttp2" "libnghttp2")))
(substitute* (jlpath "OpenBLAS")
@@ -318,7 +318,7 @@ (define-public julia
(substitute* "stdlib/PCRE2_jll/test/runtests.jl"
(("10.40.0") ,(package-version (this-package-input "pcre2"))))
(substitute* "stdlib/MbedTLS_jll/test/runtests.jl"
- (("2.28.0") ,(package-version (this-package-input "mbedtls-apache"))))
+ (("2.28.0") ,(package-version (this-package-input "mbedtls"))))
(substitute* "stdlib/MPFR_jll/test/runtests.jl"
(("4.1.0") ,(package-version (this-package-input "mpfr"))))
(substitute* "stdlib/GMP_jll/test/runtests.jl"
@@ -515,7 +515,7 @@ (define-public julia
("libunwind" ,libunwind-julia)
("libuv" ,libuv-julia)
("llvm" ,llvm-julia)
- ("mbedtls-apache" ,mbedtls-apache)
+ ("mbedtls" ,mbedtls-lts)
("mpfr" ,mpfr)
,@(if (target-x86-64?)
`(("openblas" ,openblas-ilp64))
@@ -184,7 +184,7 @@ (define-public bctoolbox
(with-directory-excursion "tester"
(invoke "./bctoolbox_tester"))))))))
(inputs
- (list bcunit libdecaf mbedtls-apache))
+ (list bcunit libdecaf mbedtls-lts))
(synopsis "Belledonne Communications Tool Box")
(description "BcToolBox is an utilities library used by Belledonne
Communications software like belle-sip, mediastreamer2 and linphone.")
@@ -2335,7 +2335,7 @@ (define-public dislocker
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ;no test suite
- (inputs (list fuse-2 mbedtls-apache))
+ (inputs (list fuse-2 mbedtls-lts))
(synopsis "FUSE driver to read/write Windows BitLocker drives")
(description
"This package provides means to to read BitLocker encrypted
@@ -832,7 +832,7 @@ (define-public nng
(substitute* "src/supplemental/websocket/CMakeLists.txt"
(("nng_test\\(wssfile_test\\)") "")))))))
(native-inputs (list oksh))
- (inputs (list mbedtls-apache))
+ (inputs (list mbedtls-lts))
(synopsis "Lightweight messaging library")
(description "NNG project is a rewrite of the scalability protocols library
known as libnanomsg, and adds significant new capabilities, while retaining
@@ -374,7 +374,7 @@ (define-public dataparksearch
(list aspell
c-ares
libextractor
- mbedtls-apache
+ mbedtls-lts
postgresql
zlib))
(synopsis "Feature rich search engine")
@@ -973,9 +973,9 @@ (define-public perl-crypt-openssl-random
number generator")
(license license:perl-license)))
-(define-public mbedtls-apache
+(define-public mbedtls-lts
(package
- (name "mbedtls-apache")
+ (name "mbedtls")
(version "2.28.7")
(source
(origin
@@ -1007,13 +1007,16 @@ (define-public mbedtls-apache
(home-page "https://www.trustedfirmware.org/projects/mbed-tls/")
(license (list license:asl2.0 license:gpl2+)))) ;dual licensed
+(define-public mbedtls-apache
+ (deprecated-package "mbedtls-apache" mbedtls-lts))
+
;; The Hiawatha Web server requires some specific features to be enabled.
(define-public mbedtls-for-hiawatha
(hidden-package
(package
- (inherit mbedtls-apache)
+ (inherit mbedtls-lts)
(arguments
- (substitute-keyword-arguments (package-arguments mbedtls-apache)
+ (substitute-keyword-arguments (package-arguments mbedtls-lts)
((#:phases phases)
#~(modify-phases #$phases
(add-before 'configure 'configure-extra-features
@@ -3936,7 +3936,7 @@ (define-public obs
libxcomposite
libxkbcommon
luajit
- mbedtls-apache
+ mbedtls-lts
mesa
pciutils
pipewire
@@ -6490,7 +6490,7 @@ (define-public hiawatha
;; Make sure 'hiawatha' finds 'mbedtls'.
(let* ((out (assoc-ref outputs "out"))
(sbin (string-append out "/sbin"))
- (mbed (assoc-ref inputs "mbedtls-apache")))
+ (mbed (assoc-ref inputs "mbedtls")))
(wrap-program (string-append sbin "/hiawatha")
`("PATH" ":" prefix (,mbed)))))))))
(inputs