[bug#76895,2/2] gnu: senpai: Remove redundant mkdir-p calls.

Message ID 03f6bea456e6cd8303ad69df74b25bacac758f8d.1741537589.git.lgcoelho@disroot.org
State New
Headers
Series Improve senpai package integration and cleanup |

Commit Message

Luis Guilherme Coelho March 9, 2025, 4:44 p.m. UTC
  * gnu/packages/messaging.scm (senpai)[arguments]<#:phases>:
{install-doc}: Remove unecessary mkdir-p calls.

Change-Id: I819561888579e86fc9f8e534d54fb79240fe2f09
---
 gnu/packages/messaging.scm | 16 ++++++----------
 1 file changed, 6 insertions(+), 10 deletions(-)
  

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index a19673a463..04dd0afbc8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3713,16 +3713,12 @@  (define-public senpai
                            "-C" (string-append "src/" unpack-path))))
                (add-after 'install 'install-doc
                  (lambda* (#:key unpack-path #:allow-other-keys)
-                   (let ((man1 (string-append #$output "/share/man/man1"))
-                         (man5 (string-append #$output "/share/man/man5")))
-                     (mkdir-p man1)
-                     (mkdir-p man5)
-                     (install-file
-                      (string-append "src/" unpack-path "/doc/senpai.1")
-                      man1)
-                     (install-file
-                      (string-append "src/" unpack-path "/doc/senpai.5")
-                      man5))))
+                   (install-file
+                    (string-append "src/" unpack-path "/doc/senpai.1")
+                    (string-append #$output "/share/man/man1"))
+                   (install-file
+                    (string-append "src/" unpack-path "/doc/senpai.5")
+                    (string-append #$output "/share/man/man5"))))
                (add-after 'install 'install-desktop-file
                 (lambda* (#:key unpack-path #:allow-other-keys)
                   (install-file