diff mbox series

[bug#61163] gnu: emacs-pretty-speedbar: New package.

Message ID 03b4f86e0640db7f8befc96e37a4793267886b85.1675060565.git.law@martinmarshall.com
State New
Headers show
Series [bug#61163] gnu: emacs-pretty-speedbar: New package. | expand

Commit Message

Martin Marshall Jan. 30, 2023, 6:36 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-pretty-speedbar): New package.
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 1bed1d848166a4081051b4e87a5ec4942ddb3397

Comments

Nicolas Goaziou Jan. 31, 2023, 2:05 p.m. UTC | #1
Hello,

Martin Marshall <law@martinmarshall.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-pretty-speedbar): New package.

Thank you. Some comments follow.

> +(define-public emacs-pretty-speedbar
> +  (let ((commit "56dc9f114fcc55843e182cde1fc9d7a14c261c6a")
> +        (revision "0"))
> +    (package
> +      (name "emacs-pretty-speedbar")
> +      (version "0.2")

This should be (git-version "0.2" revision commit) since you're not
using the exact commit where the version bump happened.

> +      (source (origin
> +                (uri (git-reference
> +                      (url "https://github.com/kcyarn/pretty-speedbar")
> +                      (commit commit)))
> +                (method git-fetch)
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "1hz67jhvg9n9d07lil6zqciqhh512k0fv54dl605p7vi704ma2ir"))))
> +      (build-system emacs-build-system)
> +      (propagated-inputs (list font-awesome))

It seems the project requires Font Awesome 6, but Guix only provides
version 4. Is it an issue?

It may be worth considering updating font-awesome in Guix first, but
I don't know what its freedom status is nowadays (as a data point,
Parabola provides it, tho).

> +      (description
> +       "Generate and implement appealing SVG icons for the Emacs
> Speedbar.  

This is not a complete sentence.

Could you send an updated patch?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ad3603b205..e1dd10fe9c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -6952,6 +6952,31 @@  (define-public emacs-sqlite3-api
 SQLite C interface, but should satisfy most user's needs.")
     (license license:gpl3+)))
 
+(define-public emacs-pretty-speedbar
+  (let ((commit "56dc9f114fcc55843e182cde1fc9d7a14c261c6a")
+        (revision "0"))
+    (package
+      (name "emacs-pretty-speedbar")
+      (version "0.2")
+      (source (origin
+                (uri (git-reference
+                      (url "https://github.com/kcyarn/pretty-speedbar")
+                      (commit commit)))
+                (method git-fetch)
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1hz67jhvg9n9d07lil6zqciqhh512k0fv54dl605p7vi704ma2ir"))))
+      (build-system emacs-build-system)
+      (propagated-inputs (list font-awesome))
+      (home-page "https://github.com/kcyarn/pretty-speedbar")
+      (synopsis "SVG icons for Emacs Speedbar")
+      (description
+       "Generate and implement appealing SVG icons for the Emacs Speedbar.  By
+default, it generates icons from the Font Awesome fontset but can use
+alternative fonts.  The color of the icons may also be customized.")
+      (license license:gpl3+))))
+
 (define-public emacs-sr-speedbar
   (let ((commit "77a83fb50f763a465c021eca7343243f465b4a47")
         (revision "0"))