diff mbox series

[bug#65226,v2] gnu: scsh: Fix version number and use gexps.

Message ID 0380706921f8f64cf116af4f7479d6dfebb951ab.1691754518.git.whatson@tailcall.au
State New
Headers show
Series [bug#65226,v2] gnu: scsh: Fix version number and use gexps. | expand

Commit Message

Andrew Whatson Aug. 11, 2023, 11:48 a.m. UTC
* gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
Use git-version.  Correct base version number to 0.7.
[source]: Use git-file-name.
[arguments]: Use gexps and remove trailing #t in phases.
---
 gnu/packages/shells.scm | 32 ++++++++++++++++----------------
 1 file changed, 16 insertions(+), 16 deletions(-)


base-commit: ad4520b92662e42d7d0b1e648b2068300dbb95c8

Comments

Ludovic Courtès Aug. 12, 2023, 9:14 p.m. UTC | #1
Hi,

Andrew Whatson <whatson@tailcall.au> skribis:

> * gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
> Use git-version.  Correct base version number to 0.7.
> [source]: Use git-file-name.
> [arguments]: Use gexps and remove trailing #t in phases.

Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..62b682496e 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -602,36 +602,36 @@  (define-public xonsh
     (license license:bsd-2)))
 
 (define-public scsh
-  (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
-        (revision "1"))
+  (let ((commit "4acf6e4ed7b65b46186ef0c9c2a1e10bef8dc052")
+        (revision "0"))
     (package
       (name "scsh")
-      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (version (git-version "0.7" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/scheme/scsh")
                (commit commit)))
-         (file-name (string-append name "-" version "-checkout"))
+         (file-name (git-file-name name version))
          (sha256
           (base32
-           "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+           "1czrp808v5gs0ci5lmkp3wr3gfkrb3vd5b2iw2hz1bpqgaf6bxpv"))
          (patches (search-patches "scsh-nonstring-search-path.patch"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:test-target "test"
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'configure 'replace-rx
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let* ((rx (assoc-ref inputs "scheme48-rx"))
-                      (rxpath (string-append rx "/share/scheme48-"
-                                             ,(package-version scheme48)
+       (list
+        #:test-target "test"
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-before 'configure 'replace-rx
+              (lambda _
+                (let ((rxpath (string-append #$scheme48-rx
+                                             "/share/scheme48-"
+                                             #$(package-version scheme48)
                                              "/rx")))
-                 (delete-file-recursively "rx")
-                 (symlink rxpath "rx"))
-               #t)))))
+                  (delete-file-recursively "rx")
+                  (symlink rxpath "rx")))))))
       (inputs
        (list scheme48 scheme48-rx))
       (native-inputs