diff mbox series

[bug#61253,core-updates,15/19] gnu: font-dseg: Simplify "install" phase.

Message ID 037c0b4bd82e3590131d4f344fb75161719ea694.1675425307.git.simon@simonsouth.net
State New
Headers show
Series Add license files missing from font packages | expand

Commit Message

Simon South Feb. 3, 2023, 12:43 p.m. UTC
* gnu/packages/fonts.scm (font-dseg)[source]: Use url-fetch.
[arguments]<#:phases>: Remove "with-directory-excursion" from "install" phase.
---
 gnu/packages/fonts.scm | 12 ++++--------
 1 file changed, 4 insertions(+), 8 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 3e9bd193fc..335ce9885f 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2176,7 +2176,7 @@  (define-public font-dseg
     (version "0.46")
     (source
       (origin
-        (method url-fetch/zipbomb)
+        (method url-fetch)
         (uri
           (string-append "https://github.com/keshikan/DSEG/"
                          "releases/download/v" version
@@ -2194,13 +2194,9 @@  (define-public font-dseg
              (let* ((out (assoc-ref outputs "out"))
                     (font-dir (string-append out "/share/fonts"))
                     (truetype-dir (string-append font-dir "/truetype")))
-               (with-directory-excursion
-                 (string-append "fonts-DSEG_v"
-                                (apply string-append (string-split ,version
-                                                                   #\.)))
-                 (for-each (lambda (f) (install-file f truetype-dir))
-                           (find-files "." "\\.ttf$"))
-               #t)))))))
+               (for-each (lambda (f) (install-file f truetype-dir))
+                         (find-files "." "\\.ttf$"))
+               #t))))))
     (home-page "https://www.keshikan.net/fonts-e.html")
     (synopsis "DSEG: 7-segment and 14-segment fonts")
     (description