[bug#75619,v2,01/10] gnu: Add soundtouch-1/integer-samples.
Commit Message
* gnu/packages/audio.scm (soundtouch-1/integer-samples): New variable.
Change-Id: Iea6e1313f2c7189ded9abf100f07ed530793f9f0
---
gnu/packages/audio.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)
base-commit: 0b06a5bc97938cae3da19e566c2f6f71cc299d78
@@ -11,7 +11,7 @@
;;; Copyright © 2016–2023 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020, 2024 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 okapi <okapi@firemail.cc>
-;;; Copyright © 2018, 2020, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018, 2020, 2022-2025 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2018, 2019, 2022 Marius Bakke <marius@gnu.org>
@@ -4355,6 +4355,30 @@ (define-public soundtouch
control functionality, or just for playing around with the sound effects.")
(license license:lgpl2.1+)))
+(define-public soundtouch-1/integer-samples
+ (package
+ (inherit soundtouch)
+ (name "soundtouch")
+ (version "1.9.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/soundtouch/soundtouch.git")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ir961w5gz86cm6yivr1ypi6n2y52vn319gy2gvdkkbbz5wyjkrq"))))
+ (arguments
+ ;; Dolphin expects the samples to be of the integer type.
+ (list #:configure-flags #~(list "--enable-integer-samples")
+ #:phases #~(modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; Avoid the bootstrap script, which has a broken
+ ;; shebang.
+ (invoke "autoreconf" "-vif"))))))))
+
(define-public stargate-soundtouch
;; Stargate's fork of soundtouch.
(let ((commit "464f474c0be5d7e0970909dd30593012e4621468")