[bug#76572,v2,1/4] gnu: gnome-shell-extension-gsconnect: Fix search path patching.
Commit Message
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-gsconnect):
[arguments]<#:phases>: Fix 'fix-paths phase substitutions no longer applying.
Change-Id: I99aa0204c1dfad836aed62261d2ffc0c75366510
---
gnu/packages/gnome-xyz.scm | 21 ++++++++++++---------
1 file changed, 12 insertions(+), 9 deletions(-)
@@ -20,6 +20,7 @@
;;; Copyright © 2022 Sughosha <sughosha@proton.me>
;;; Copyright © 2022 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
;;; Copyright © 2023 Eidvilas Markevičius <markeviciuseidvilas@gmail.com>
+;;; Copyright © 2025 aurtzy <aurtzy@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -766,15 +767,17 @@ (define-public gnome-shell-extension-gsconnect
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(substitute* "data/org.gnome.Shell.Extensions.GSConnect.desktop.in"
(("gapplication") gapplication))
- (for-each
- (lambda (file)
- (substitute* file
- (("'use strict';")
- (string-append "'use strict';\n\n"
- "'" gi-typelib-path "'.split(':').forEach("
- "path => imports.gi.GIRepository.Repository."
- "prepend_search_path(path));"))))
- '("src/extension.js" "src/prefs.js")))))
+ (for-each (lambda (file)
+ (with-atomic-file-replacement
+ file
+ (lambda (input output)
+ (format output "~a"
+ (string-append
+ "'" gi-typelib-path "'.split(':').forEach("
+ "path => imports.gi.GIRepository.Repository."
+ "prepend_search_path(path));\n"))
+ (dump-port input output))))
+ '("src/extension.js" "src/prefs.js")))))
(add-after 'install 'wrap-daemons
(lambda _
(let* ((out #$output)