diff mbox series

[bug#56601] gnu: Add texlive-datetime2.

Message ID 02b20009a4ac69d0eaa4c2d17fe0b473a1d48fdf.1657982490.git.me@fabionatali.com
State Accepted
Headers show
Series [bug#56601] gnu: Add texlive-datetime2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Fabio Natali July 16, 2022, 2:42 p.m. UTC
---
 gnu/packages/tex.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 4ce7f1fb24a111f3e92d5b889d1271bebf109d09
prerequisite-patch-id: 15fbd940ff2c4d720e5400d6413ffbfdf01ead36
prerequisite-patch-id: 4b09fce4186da53607ac1503a21a16c410eb0287
prerequisite-patch-id: 59d5d41ee572d700fb228981ac6c0acbf01953a1
prerequisite-patch-id: 1b253ce7adb8a1d30efc86a877c8a69e6c0ff3ac
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6aa79c4d2c..c2824dbecd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11102,3 +11102,26 @@  (define-public texlive-pdflscape
 setting the PDF /Rotate page attribute.  Pages with this attribute will be
 displayed in landscape orientation by conforming PDF viewers.")
     (license license:lppl1.3+)))
+
+(define-public texlive-datetime2
+  (package
+    (inherit
+     (simple-texlive-package
+      "texlive-datetime2"
+      (list "doc/latex/datetime2/"
+            "source/latex/datetime2/"
+            "tex/latex/datetime2/")
+      (base32 "0yjkpfic1ni4j2g61rrjj5hjyd43shc9c0sg1aivbbsmqh30dn33")
+      #:trivial? #t))
+    (home-page "https://ctan.org/macros/latex/contrib/datetime2")
+    (synopsis "Formats for dates, times and time zones")
+    (description
+     "This package provides commands for formatting dates, times and time zones and
+redefines \\today to use the same formatting style.  In addition to \\today, you
+can also use \\DTMcurrenttime (current time) or \\DTMnow (current date and time).
+Dates and times can be saved for later use.  The accompanying datetime2-calc
+package can be used to convert date-times to UTC+00:00.  Language and regional
+support is provided by independently maintained and installed modules.  The
+datetime2-calc package uses the pgfcalendar package (part of the PGF/TikZ
+bundle).  This package replaces datetime.sty which is now obsolete.")
+    (license license:lppl1.3+)))