diff mbox series

[bug#67073] gnu: smu: Fix cross-compilation.

Message ID 029632f3e0467528f867589c2216e17b32eecd8b.1699702253.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#67073] gnu: smu: Fix cross-compilation. | expand

Commit Message

Z572 Nov. 11, 2023, 11:30 a.m. UTC
* gnu/packages/markup.scm (smu): Fix cross-compilation.
[arguments]: Use Gexp and CC-FOR-TARGET.

Change-Id: Ifb6a1962b12b31ed0092cb042670301a3ef4cfa8
---
 gnu/packages/markup.scm | 15 ++++++++-------
 1 file changed, 8 insertions(+), 7 deletions(-)


base-commit: af6105afc67a15a491a0a4fd18a28c9f801a0b94

Comments

Mathieu Othacehe Nov. 25, 2023, 1:36 p.m. UTC | #1
> * gnu/packages/markup.scm (smu): Fix cross-compilation.

Applied, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 595b08fa20..4a9a382104 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -428,13 +429,13 @@  (define-public smu
         (base32 "1jm7lhnzjx4q7gcwlkvsbffcy0zppywyh50d71ami6dnq182vvcc"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:make-flags (list "CC=gcc"
-                          (string-append "PREFIX="
-                                         (assoc-ref %outputs "out")))
-       #:tests? #f                      ; no tests included
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+     (list #:make-flags
+           #~(list (string-append "CC=" #$(cc-for-target))
+                   (string-append "PREFIX=" #$output))
+           #:tests? #f                      ; no tests included
+           #:phases
+           #~(modify-phases %standard-phases
+               (delete 'configure))))
     (home-page "https://github.com/Gottox/smu")
     (synopsis "Simple markup")
     (description