diff mbox series

[bug#39108] gnu: Add gst-editing-services.

Message ID 02823ea592a1cec21c0de7cc7efc1256bc7add09.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#39108] gnu: Add gst-editing-services. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Leo Prikler Jan. 23, 2020, 12:31 p.m. UTC
I've noticed, that staging gstreamer builds with meson now, resolving
this part of the discussion.  I've also noticed some cosmetic errors in
my initial patch, so I'm sending updated versions, one for master and
one for staging (only offsets appear to differ), so that the patch
keeps working after an eventual merge.

Regards,
Leo

Comments

Leo Prikler Feb. 11, 2020, 4:12 p.m. UTC | #1
Am Donnerstag, den 23.01.2020, 13:31 +0100 schrieb Leo Prikler:
> I've noticed, that staging gstreamer builds with meson now, resolving
> this part of the discussion.  I've also noticed some cosmetic errors
> in
> my initial patch, so I'm sending updated versions, one for master and
> one for staging (only offsets appear to differ), so that the patch
> keeps working after an eventual merge.
Just ensuring this is not forgotten.  Since staging is merged now, the
staging patch is the one to apply.
Marius Bakke Feb. 14, 2020, 3:58 p.m. UTC | #2
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> I've noticed, that staging gstreamer builds with meson now, resolving
> this part of the discussion.  I've also noticed some cosmetic errors in
> my initial patch, so I'm sending updated versions, one for master and
> one for staging (only offsets appear to differ), so that the patch
> keeps working after an eventual merge.

Oh no, I missed that you had alredy ported GStreamer to the Meson build
system in a previous email!  Sorry for the duplicate work.

I notice in this patch that gst-editing-services still uses
gnu-build-system, can you update it to use meson-build-system instead?
diff mbox series

Patch

From 76daab1a0085ef5950cde543e6b41f0559d469c2 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
 gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..85f822d 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,37 @@  distribution problems in some jurisdictions, e.g. due to patent threats.")
 compression formats through the use of the libav library.")
     (license license:gpl2+)))
 
+(define-public gst-editing-services
+  (package
+    (name "gst-editing-services")
+    (version "1.16.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://gstreamer.freedesktop.org/src/" name "/"
+                    "gstreamer-editing-services-" version ".tar.xz"))
+              (sha256
+               (base32
+                "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; TODO: 16/22 failing tests with meson, 21 with gnu
+     `(#:tests? #f))
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("libxml2" ,libxml2)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer library for non-linear editors")
+    (description
+     "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+    (license license:gpl2+)))
+
 (define-public python-gst
   (package
     (name "python-gst")
--
libgit2 0.28.4