diff mbox series

[bug#64660] gnu: Add emacs-heaven-and-hell.

Message ID 0279082734e9b48c20cb4dab7bc92fa6949c136b.1689489763.git.a.r.draidi@redscript.org
State New
Headers show
Series [bug#64660] gnu: Add emacs-heaven-and-hell. | expand

Commit Message

Ahmad Draidi July 16, 2023, 6:42 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-heaven-and-hell): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)


base-commit: d08bd19de0b06d5da7f2c06fb733e245b566dd54
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 480096fb50..b6837239c9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26871,6 +26871,26 @@  (define-public emacs-ztree
 @command{ztree-diff}).")
       (license license:gpl3))))
 
+(define-public emacs-heaven-and-hell
+  (package
+    (name "emacs-heaven-and-hell")
+    (version "0.0.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/valignatev/heaven-and-hell")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1bgs638nsn9hyvc9wbc2jpqm5i3hblld1mhmf0h9z0j6fjr0aapx"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/valignatev/heaven-and-hell")
+    (synopsis "Easily toggle light/dark themes in Emacs")
+    (description "This package makes the process of switching between
+light and dark themes as easy as hitting a single keystroke.")
+    (license license:expat)))
+
 (define-public emacs-helm-org-contacts
   (let ((commit "741eca6239684950219c9a12802386a132491b8c")
         (revision "2"))