diff mbox series

[bug#68305] gnu: Add guile-srfi-197.

Message ID 021a14380a3d701f4dddbac72b83bf34bdea4558.1704640177.git.~@wolfsden.cz
State New
Headers show
Series [bug#68305] gnu: Add guile-srfi-197. | expand

Commit Message

Tomas Volf Jan. 7, 2024, 3:09 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-srfi-197): New variable.

Change-Id: Ifcdc264e6a03e88e7614d79792fbe6ca9c8e519c
---
 gnu/packages/guile-xyz.scm | 56 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)


base-commit: b212e6934643e085f168a5364cb593f61aa616ba

Comments

Mathieu Othacehe Jan. 12, 2024, 4:10 p.m. UTC | #1
Hello,

> +(define-public guile-srfi-197
> +  (let ((commit "d31b8be86460bf837cccf2737a1b9b9c01788573")
> +        (revision "0"))

You should explain why you are not using a release with a comment. The
"final" tag for instance.

> +        #~(modify-phases %standard-phases
> +            (add-after 'unpack 'create-module
> +              (λ _

Please use 'lambda'.

> +SRFI defines a family of chain and nest pipeline operators, which can rewrite
> +nested expressions like (a b (c d (e f g))) as a sequence of operations:

@code{(a b (c d (e f g)))}

> +(chain g (e f _) (c d _) (a b _)).")

@code{(chain g (e f _) (c d _) (a b _)).")}

Can you please send a v2?

Thanks,

Mathieu
Tomas Volf Jan. 12, 2024, 4:47 p.m. UTC | #2
On 2024-01-12 17:10:50 +0100, Mathieu Othacehe wrote:
> 
> Hello,
> 
> > +(define-public guile-srfi-197
> > +  (let ((commit "d31b8be86460bf837cccf2737a1b9b9c01788573")
> > +        (revision "0"))
> 
> You should explain why you are not using a release with a comment. The
> "final" tag for instance.

Comment added.

> 
> > +        #~(modify-phases %standard-phases
> > +            (add-after 'unpack 'create-module
> > +              (λ _
> 
> Please use 'lambda'.

I replaced all occurrences.  Is there something regarding this in the manual?  I
see no mention of it and guix style leaves it as it is.  There are few (~5) uses
in the repository already, so I assumed it is permitted.

> 
> > +SRFI defines a family of chain and nest pipeline operators, which can rewrite
> > +nested expressions like (a b (c d (e f g))) as a sequence of operations:
> 
> @code{(a b (c d (e f g)))}
> 
> > +(chain g (e f _) (c d _) (a b _)).")
> 
> @code{(chain g (e f _) (c d _) (a b _)).")}
> 
> Can you please send a v2?

Done and done.

Have a nice day,
Tomas Volf
Mathieu Othacehe Jan. 13, 2024, 9:22 a.m. UTC | #3
Hey,

> I replaced all occurrences.  Is there something regarding this in the manual?  I
> see no mention of it and guix style leaves it as it is.  There are few (~5) uses
> in the repository already, so I assumed it is permitted.

I don't think it is advised not to use that anywhere but the reason to
me is the consistency of the code base. It would be nice to remove the 5
existing use that you are reporting :)

> Done and done.

Perfect, thanks,

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 75e3754046..ff3104a407 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -3840,6 +3840,62 @@  (define-public guile-srfi-189
 or errors (Left).")
       (license license:expat))))
 
+(define-public guile-srfi-197
+  (let ((commit "d31b8be86460bf837cccf2737a1b9b9c01788573")
+        (revision "0"))
+    (package
+      (name "guile-srfi-197")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/scheme-requests-for-implementation/srfi-197")
+               (commit commit)))
+         (sha256
+          (base32
+           "1c1jjzqgavjwfzs352wssdbjga5ymv4g3lkl0zxhjw7pfrr5xx1m"))
+         (file-name (git-file-name name version))))
+      (build-system guile-build-system)
+      (arguments
+       (list
+        #:source-directory "src"
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-after 'unpack 'create-module
+              (λ _
+                (use-modules (ice-9 textual-ports))
+                (mkdir-p "src/srfi")
+                (call-with-output-file "src/srfi/srfi-197.scm"
+                  (λ (port)
+                    (write '(define-module (srfi srfi-197)
+                              #:use-module (scheme base)
+                              #:export (chain
+                                        chain-and
+                                        chain-when
+                                        chain-lambda
+                                        nest
+                                        nest-reverse))
+                           port)
+                    (call-with-input-file "srfi-197-syntax-case.scm"
+                      (λ (in-port)
+                        (display (get-string-all in-port) port)))))))
+            (add-after 'install 'check-installed
+              (λ _
+                (define-values (scm go) (target-guile-scm+go #$output))
+                (invoke "guile" "-L" scm "-C" go
+                        "--use-srfi=197" "./test.scm"))))))
+      (native-inputs
+       (list guile-3.0))
+      (home-page "https://srfi.schemers.org/srfi-197/")
+      (synopsis "Pipeline operators for Guile")
+      (description
+       "This library provides a reference implementation for SRFI-197.  This
+SRFI defines a family of chain and nest pipeline operators, which can rewrite
+nested expressions like (a b (c d (e f g))) as a sequence of operations:
+(chain g (e f _) (c d _) (a b _)).")
+      (license license:expat))))
+
 (define-public guile-srfi-232
   (package
     (name "guile-srfi-232")