[bug#78069,1/1] gnu: libsecret: Add bin output.

Message ID 018f32164cb7c57ce49baa0d6a7d391e787d5806.1745625923.git.gabrielsantosdesouza@disroot.org
State New
Headers
Series libsecret: Add bin output. |

Commit Message

Gabriel Santos April 26, 2025, 12:05 a.m. UTC
  * gnu/packages/gnome.scm (libsecret): Add "bin" output.

Change-Id: I4f07c0f040b980b557c72d299fb02e8ccb2cb521
---
 gnu/packages/gnome.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)


base-commit: 7ff20b9e94c429f1160bd8f0db86b153a03e4683
  

Comments

Gabriel Santos April 26, 2025, 11:45 a.m. UTC | #1
> The only thing missing is the man page, not sure how I would go about
> adding it to the output.

Nevermind, I figured it out. Sending a v2 soon.
  

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 34162d5138..37a5b1745e 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5355,10 +5355,13 @@  (define-public libsecret
                (base32
                 "081bj59ws08kb261cd1w1mkdkhfbzsjbbkkrm6wllvdyhgbhhg8n"))))
     (build-system meson-build-system)
+    (outputs '("out" "bin"))
     (arguments
      (list
       #:configure-flags
-      #~(list "-Dgtk_doc=false")        ;requires gi-docgen
+      #~(list "-Dgtk_doc=false" ;requires gi-docgen
+              (string-append "--bindir="
+                             #$output:bin "/bin"))
       #:phases
       #~(modify-phases %standard-phases
           (delete 'check)
@@ -5367,7 +5370,7 @@  (define-public libsecret
               (when tests?
                 (setenv "HOME" "/tmp")
                 (setenv "XDG_DATA_DIRS" ;for /org/freedesktop/secrets/collection
-                        (string-append #$output "/share:"
+                        (string-append #$output:out "/share:"
                                        (getenv "XDG_DATA_DIRS")))
                 (apply invoke "dbus-run-session" "--"
                        "meson" "test" "--print-errorlogs" "-t" "0"