[bug#75176,01/18] gnu: Add go-github-com-fatih-structs.
Commit Message
* gnu/packages/golang-xyz.scm (go-github-com-fatih-structs): New variable.
Change-Id: I7c2f90845754991253fcfa9699746d98ac030ff1
---
gnu/packages/golang-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
@@ -3101,6 +3101,29 @@ (define-public go-github-com-fatih-color
defined output to the standard output.")
(license license:expat)))
+(define-public go-github-com-fatih-structs
+ (package
+ (name "go-github-com-fatih-structs")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/fatih/structs")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1wrhb8wp8zpzggl61lapb627lw8yv281abvr6vqakmf569nswa9q"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/fatih/structs"))
+ (home-page "https://github.com/fatih/structs")
+ (synopsis "Utilities for Go structs")
+ (description "This package provides various utilitiy functions to work
+with Go structs.")
+ (license license:expat)))
+
;; XXX: This repository has been archived by the owner on Nov 9, 2017. It is
;; now read-only.
(define-public go-github-com-flynn-archive-go-shlex