diff mbox series

[bug#66593] gnu: cups: Fix cross-compiling.

Message ID 01589deed1d8ce00f26af78aca76fce3cb8a7317.1697553836.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#66593] gnu: cups: Fix cross-compiling. | expand

Commit Message

Zheng Junjie Oct. 17, 2023, 2:43 p.m. UTC
* gnu/packages/cups.scm (cups-filters)[native-inputs]: When cross-compiling
add cups-minimal.
(cups-minimal)[native-inputs]: When cross-compiling add this-package.
---
 gnu/packages/cups.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)


base-commit: e80022ff3adde3184bed6758f604e3aa12942865

Comments

Mathieu Othacehe Oct. 26, 2023, 8:31 a.m. UTC | #1
> * gnu/packages/cups.scm (cups-filters)[native-inputs]: When cross-compiling
> add cups-minimal.
> (cups-minimal)[native-inputs]: When cross-compiling add this-package.

Tested with:

--8<---------------cut here---------------start------------->8---
./pre-inst-env guix build cups --target=aarch64-linux-gnu
--8<---------------cut here---------------end--------------->8---

and builds fine.

Applied, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 647b89dc03..fc26fd70ca 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2021, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -204,8 +205,11 @@  (define-public cups-filters
                     (find-files (string-append #$output
                                                "/lib/cups/filter"))))))))
     (native-inputs
-     (list `(,glib "bin")               ; for gdbus-codegen
-           pkg-config))
+     (append (if (%current-target-system)
+                 (list cups-minimal)
+                 '())
+             (list `(,glib "bin")               ; for gdbus-codegen
+                   pkg-config)))
     (inputs
      (list avahi
            fontconfig
@@ -315,7 +319,10 @@  (define-public cups-minimal
                      ;; to a missing font.  Substitute the last observed count.
                      (("(\\$count != )33" _ prefix)
                       (string-append prefix "39"))))))))
-    (native-inputs (list config pkg-config))
+    (native-inputs (cons* config pkg-config
+                          (if (%current-target-system)
+                              (list this-package)
+                              '())))
     (inputs (list zlib gnutls))
     (home-page "https://openprinting.github.io/cups")
     (synopsis "The Common Unix Printing System")