diff mbox series

[bug#62473,v4,2/2] gnu: Add openfoam-com.

Message ID 01020188ef5c39ae-e41f2b42-59d3-4e3b-886f-238c53bc915a-000000@eu-west-1.amazonses.com
State New
Headers show
Series [bug#62473,v4,1/2] gnu: Add openfoam-org. Deprecate openfoam. | expand

Commit Message

reza June 24, 2023, 9:42 p.m. UTC
* gnu/packages/simulation.scm (openfoam-com): New variable.
---
 gnu/packages/simulation.scm | 43 +++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

-- 
2.40.1

Comments

Ludovic Courtès Aug. 10, 2023, 7:48 a.m. UTC | #1
Hi reza,

Finally pushed as 997b38badaee20a1c60411e5e599e260e47785ec.

I had to fix a number of things: line endings were still DOS-style,
requiring a manual edit, a module import was missing, there was a typo
“which "sh"” (without parens) that I changed to just "sh", there was a
circular dependency caused by engineering.scm that needed to be fixed,
and the synopsis of ‘openfoam-com’ had been left unchanged contrary to
what we had discussed.

So quite a lot of work.  Please pay more attention to review feedback
next time so we can more quickly process patches.

The good news is that this new version of OpenFoam is in now, yay!

Thanks,
Ludo’.
Hilton Chain Aug. 10, 2023, 10:23 a.m. UTC | #2
Hi,

On Thu, 10 Aug 2023 15:48:12 +0800,
Ludovic Courtès wrote:
>
> I had to fix a number of things: line endings were still DOS-style,
> requiring a manual edit

Patchwork (QA page of the issue -> View series on Patchwork) seems to
handle this really well, I tried to download the series there and the
file uses LF for line endings.
diff mbox series

Patch

diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 303b7d8d5a..5f7a6b5078 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -396,6 +396,49 @@  (define-public openfoam-org
 (define-public openfoam
   (deprecated-package "openfoam" openfoam-org))
 
+(define-public openfoam-com
+  (package
+    (inherit openfoam-org)
+    (name "openfoam-com")
+    (version "2212")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://develop.openfoam.com"
+                                  "/Development/openfoam/-/archive/OpenFOAM-v"
+                                  version
+                                  "/openfoam-OpenFOAM-v"
+                                  version
+                                  ".tar.gz"))
+              (sha256
+               (base32
+                "0i9039hfz9gvgymkdjhjvvn5500zha3cpdbpqrzfrfi8lbz10is2"))
+              (modules '((guix build utils)))
+              (snippet `(begin
+                          (substitute* "etc/bashrc"
+                            ;; set same version as guix package
+			    (("^export WM_PROJECT_VERSION=.*$")
+			     (string-append "export WM_PROJECT_VERSION="
+					    ,version "\n")))
+                          ;; patch shell paths
+                          (substitute* (list "src/OSspecific/POSIX/POSIX.C"
+                                             "wmake/src/Makefile"
+                                             "wmake/makefiles/general"
+                                             "wmake/makefiles/info")
+                            (("/bin/sh")
+                             which "sh"))))))
+    (description
+     "OpenFOAM is a free, open source CFD software released and developed by
+OpenCFD Ltd since 2004.  It has a large user base across most areas of
+engineering and science, from both commercial and academic organizations.
+OpenFOAM has an extensive range of features to solve anything from complex
+fluid flows involving chemical reactions, turbulence and heat transfer, to
+acoustics, solid mechanics and electromagnetics.  See documentation OpenFOAM
+is professionally released every six months to include customer sponsored
+developments and contributions from the community - individual and group
+contributors, integrations (eg, from FOAM-extend and OpenFOAM Foundation Ltd)
+as well as governance guided activities.")
+    (home-page "https://www.openfoam.com")))
+
 (define-public open-simulation-interface
   (package
     (name "open-simulation-interface")