diff mbox series

[bug#62473,4/4] gnu: Add openfoam-com.

Message ID 0102018722083b4f-30bfa143-ae1d-4328-98c1-4cfd34eede77-000000@eu-west-1.amazonses.com
State New
Headers show
Series [bug#62473,1/4] gnu: Add ftest. | expand

Commit Message

reza March 27, 2023, 7:46 a.m. UTC
---
 gnu/packages/simulation.scm | 39 +++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

-- 
2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 685b123903..282cf6e10c 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -367,6 +367,45 @@  (define-public openfoam-org
     (license license:gpl3+)
     (home-page "https://openfoam.org")))
 
+(define-public openfoam-com
+  (package
+    (inherit openfoam-org)
+    (name "openfoam-com")
+    (version "2212")
+    (source (origin
+              (method url-fetch)
+
+              (uri (string-append "https://develop.openfoam.com"
+                    "/Development/openfoam/-/archive/OpenFOAM-v"
+                    version
+                    "/openfoam-OpenFOAM-v"
+                    version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "0i9039hfz9gvgymkdjhjvvn5500zha3cpdbpqrzfrfi8lbz10is2"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          ;; patch shell paths
+                          (substitute* (list "src/OSspecific/POSIX/POSIX.C"
+                                             "wmake/src/Makefile"
+                                             "wmake/makefiles/general"
+                                             "wmake/makefiles/info")
+                            (("/bin/sh")
+                             which "sh"))))))
+    (description
+     "OpenFOAM is a free, open source CFD software released and developed by
+OpenCFD Ltd since 2004.  It has a large user base across most areas of
+engineering and science, from both commercial and academic organizations.
+OpenFOAM has an extensive range of features to solve anything from complex
+fluid flows involving chemical reactions, turbulence and heat transfer, to
+acoustics, solid mechanics and electromagnetics.  See documentation OpenFOAM
+is professionally released every six months to include customer sponsored
+developments and contributions from the community - individual and group
+contributors, integrations (eg, from FOAM-extend and OpenFOAM Foundation Ltd)
+as well as governance guided activities.")
+    (home-page "https://www.openfoam.com")))
+
 (define-public open-simulation-interface
   (package
     (name "open-simulation-interface")