diff mbox series

[bug#66199,v2,1/2] gnu: Add fontobene-qt5.

Message ID 00f8b2031e0af268e413cefa7dea3eeba4775582.1695729169.git.pinoaffe@gmail.com
State New
Headers show
Series [bug#66199,v2,1/2] gnu: Add fontobene-qt5. | expand

Commit Message

pinoaffe Sept. 26, 2023, 12:16 p.m. UTC
* gnu/packages/fontutils.scm (fontobene-qt5): New variable.
---
 gnu/packages/fontutils.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)


base-commit: 445a0359083388b5ee686e6e855f94a3aac5f79c

Comments

Vinicius Monego Sept. 27, 2023, 12:39 a.m. UTC | #1
Hi,

Em 26/09/2023 09:16, pinoaffe escreveu:
> * gnu/packages/fontutils.scm (fontobene-qt5): New variable.
> ---
>   gnu/packages/fontutils.scm | 30 ++++++++++++++++++++++++++++++
>   1 file changed, 30 insertions(+)
>
> diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
> index 230fdd1dde..71a4f156b0 100644
> --- a/gnu/packages/fontutils.scm
> +++ b/gnu/packages/fontutils.scm
> @@ -18,6 +18,7 @@
>   ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
>   ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
>   ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
> +;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
>   ;;;
>   ;;; This file is part of GNU Guix.
>   ;;;
> @@ -65,6 +66,7 @@ (define-module (gnu packages fontutils)
>     #:use-module (gnu packages python)
>     #:use-module (gnu packages python-build)
>     #:use-module (gnu packages python-xyz)
> +  #:use-module (gnu packages qt)
>     #:use-module (gnu packages sqlite)
>     #:use-module (gnu packages webkit)
>     #:use-module (gnu packages xdisorg)
> @@ -951,6 +953,34 @@ (define-public python-ufonormalizer
>   @end itemize")
>       (license license:bsd-3)))
>   
> +(define-public fontobene-qt5
> +  (package
> +    (name "fontobene-qt5")
> +    (version "0.2.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/fontobene/fontobene-qt5")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0gy3sfraf23k7dm4ha8nqpd6madzk0zmxkcb204micyn5b5l8ljg"))))
> +    (inputs (list qtbase-5))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:phases
> +       (modify-phases %standard-phases
> +         (replace 'check
> +           (lambda* (#:key tests? #:allow-other-keys)
> +             (when tests?
> +               (invoke "./tests/fontobene-qt5-tests")))))))
> +    (home-page "https://github.com/fontobene/fontobene-qt5")
> +    (synopsis "Parser for FontoBene stroke fonts")
> +    (description "A header-only library to parse FontoBene stroke fonts with
> +C++11/Qt5.")

Descriptions should be full sentences (subject + predicate). The linter 
should be able to catch this. Otherwise LGTM.

> +    (license license:expat)))
> +
>   (define-public ttfautohint
>     (package
>       (name "ttfautohint")
>
> base-commit: 445a0359083388b5ee686e6e855f94a3aac5f79c

Vinicius
pinoaffe Sept. 27, 2023, 4:11 p.m. UTC | #2
Thanks for the review!

Vinicius Monego <monego@posteo.net> writes:

> Hi,
>
> Em 26/09/2023 09:16, pinoaffe escreveu:
>> +    (description "A header-only library to parse FontoBene stroke fonts with
>> +C++11/Qt5.")
> Descriptions should be full sentences (subject + predicate). The
> linter should be able to catch this. Otherwise LGTM.

For whatever reason it didn't catch this, but this should be fixed with
v3 of the patch series

Kind regards, pinoaffe
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 230fdd1dde..71a4f156b0 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -65,6 +66,7 @@  (define-module (gnu packages fontutils)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages webkit)
   #:use-module (gnu packages xdisorg)
@@ -951,6 +953,34 @@  (define-public python-ufonormalizer
 @end itemize")
     (license license:bsd-3)))
 
+(define-public fontobene-qt5
+  (package
+    (name "fontobene-qt5")
+    (version "0.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fontobene/fontobene-qt5")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0gy3sfraf23k7dm4ha8nqpd6madzk0zmxkcb204micyn5b5l8ljg"))))
+    (inputs (list qtbase-5))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "./tests/fontobene-qt5-tests")))))))
+    (home-page "https://github.com/fontobene/fontobene-qt5")
+    (synopsis "Parser for FontoBene stroke fonts")
+    (description "A header-only library to parse FontoBene stroke fonts with
+C++11/Qt5.")
+    (license license:expat)))
+
 (define-public ttfautohint
   (package
     (name "ttfautohint")