diff mbox series

[bug#68543,24/24] gnu: Add rust-grep-0.3.

Message ID 00db015079c53066548d379fd0e2e6c18b6529e2.1705515116.git.mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#68543,01/24] gnu: rust-memchr-2: Update to 2.7.1. | expand

Commit Message

Nicolas Goaziou Jan. 17, 2024, 6:22 p.m. UTC
* gnu/packages/crates-io.scm (rust-grep-0.3): New variable.
(rust-grep-0.2): Inherit from above.

Change-Id: Iceba38b4a103a480de791c92683fb84dc071f9dc
---
 gnu/packages/crates-io.scm | 38 +++++++++++++++++++++++++++++++-------
 1 file changed, 31 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 57014ab476..fc2e819a35 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33656,8 +33656,38 @@  (define-public rust-greetd-ipc-0.8
              ("rust-thiserror" ,rust-thiserror-1)
              ("rust-tokio" ,rust-tokio-1))))))
 
+(define-public rust-grep-0.3
+  (package
+    (name "rust-grep")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "grep" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0fa9x7q3l5z0bg91wzw1jfpk5rmh60h8bswbsxjcp1p6q5704avf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-grep-cli" ,rust-grep-cli-0.1)
+        ("rust-grep-matcher" ,rust-grep-matcher-0.1)
+        ("rust-grep-pcre2" ,rust-grep-pcre2-0.1)
+        ("rust-grep-printer" ,rust-grep-printer-0.2)
+        ("rust-grep-regex" ,rust-grep-regex-0.1)
+        ("rust-grep-searcher" ,rust-grep-searcher-0.1))
+       #:cargo-development-inputs
+       (("rust-termcolor" ,rust-termcolor-1)
+        ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/BurntSushi/ripgrep")
+    (synopsis "Line oriented regex searching as a library")
+    (description "This crate provides a fast line oriented regex searching as
+a library.")
+    (license (list license:unlicense license:expat))))
+
 (define-public rust-grep-0.2
   (package
+    (inherit rust-grep-0.3)
     (name "rust-grep")
     (version "0.2.8")
     (source
@@ -33669,7 +33699,6 @@  (define-public rust-grep-0.2
        (sha256
         (base32
          "0mw61v132ng0nbz5ygb6jvsx729772803w5bv3zs4i8baq689jsi"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:skip-build? #t
        #:cargo-inputs
@@ -33681,12 +33710,7 @@  (define-public rust-grep-0.2
         ("rust-grep-searcher" ,rust-grep-searcher-0.1))
        #:cargo-development-inputs
        (("rust-termcolor" ,rust-termcolor-1)
-        ("rust-walkdir" ,rust-walkdir-2))))
-    (home-page "https://github.com/BurntSushi/ripgrep")
-    (synopsis "Line oriented regex searching as a library")
-    (description
-     "Fast line oriented regex searching as a library.")
-    (license (list license:unlicense license:expat))))
+        ("rust-walkdir" ,rust-walkdir-2))))))
 
 (define-public rust-grep-cli-0.1
   (package