diff mbox series

[bug#66839,12/19] gnu: Add rust-color-eyre-0.6.

Message ID 00d8a48a2445f9b35970211025c287345fdc35ae.1698699809.git.steve@futurile.net
State New
Headers show
Series Series to add spotifyd | expand

Commit Message

Steve George Oct. 30, 2023, 9:06 p.m. UTC
* gnu/packages/crates-io.scm (rust-color-eyre-0.6) New variable.
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 05f47df54b..9e95e8b485 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -13951,6 +13951,35 @@  (define-public rust-coitrees-0.2
 sets of intervals.")
     (license license:expat)))
 
+(define-public rust-color-eyre-0.6
+  (package
+    (name "rust-color-eyre")
+    (version "0.6.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "color-eyre" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "014j49slcblg6cnsh974k9yjmi1khbm4dpmqdm1zii58rj1parjs"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-test-flags (list "--release" "--"
+                                "--skip=test_error_backwards_compatibility")
+       #:cargo-inputs (("rust-eyre" ,rust-eyre-0.6)
+                       ("rust-indenter" ,rust-indenter-0.3)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-owo-colors" ,rust-owo-colors-3)
+                       ("rust-color-spantrace" ,rust-color-spantrace-0.2))
+       #:cargo-development-inputs (("rust-pretty-assertions" ,rust-pretty-assertions-1))))
+    (home-page "https://github.com/eyre-rs/color-eyre")
+    (synopsis
+     "Error handler for Rust that creates colorful and consistent reports")
+    (description
+     "Rust error handling for panics and the @code{eyre} crate, that produces
+colorful, consistent, and well formatted error reports.")
+    (license license:expat)))
+
 (define-public rust-color-print-0.3
   (package
     (name "rust-color-print")