diff mbox series

[bug#74344,1/7] gnu: Add asyncplusplus.

Message ID 009f0224022cd4677679737eb01a26142e658152.1731512782.git.sughosha@disroot.org
State New
Headers show
Series gnu: Add jamesdsp. | expand

Commit Message

Sughosha Nov. 13, 2024, 3:46 p.m. UTC
* gnu/packages/cpp.scm (asyncplusplus): New variable.

Change-Id: I6ba1b983ce05a634937d0d972e670ce636df3b94
---
 gnu/packages/cpp.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: 2a6d96425eea57dc6dd48a2bec16743046e32e06
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index f8e8557ef1..23d8439d00 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -190,6 +190,33 @@  (define-public asmjit
 development effort.")
       (license license:zlib))))
 
+(define-public asyncplusplus
+  (package
+    (name "asyncplusplus")
+    (version "1.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Amanieu/asyncplusplus")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0iswbh7y46kn412c52af0n8bc4fplm3y94yh10n2lchispzar72j"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Fix install location of cmake files.
+               '(substitute* "CMakeLists.txt"
+                  (("DESTINATION cmake")
+                    "DESTINATION ${CMAKE_INSTALL_LIBDIR}/cmake")))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:tests? #f)) ;no tests
+    (home-page "https://github.com/Amanieu/asyncplusplus")
+    (synopsis "Concurrency framework for C++11")
+    (description "Async++ is a concurrency framework for C++11.")
+    (license license:expat)))
+
 (define-public biblesync
   (package
     (name "biblesync")