diff mbox series

[bug#36406,PATCHv2] gnu: Add bitcoin-abc.

Message ID 004ccd40-b7f9-1d7e-3ff3-f22a78d5d2bc@riseup.net
State Accepted
Headers show
Series [bug#36406,PATCHv2] gnu: Add bitcoin-abc. | expand

Commit Message

swedebugia Aug. 1, 2019, 8:43 p.m. UTC
On 2019-07-03 00:39, Ludovic Courtès wrote:
> Hi swedebugia,
>
> swedebugia <swedebugia@riseup.net> skribis:
>
>> >From 1ce83b0ceabac0260f6a9dc43d4df1cc75236aa7 Mon Sep 17 00:00:00 2001
>> From: swedebugia <swedebugia@riseup.net>
>> Date: Thu, 27 Jun 2019 22:06:33 +0200
>> Subject: [PATCH] gnu: Add bitcoin-abc.
>>
>> * gnu/packages/finance.scm (bitcoin-abc): New variable.
> [...]
>
>> +(define-public bitcoin-abc
>> +  ;; This is a fork of bitcoin-core and identical to upstream.
>> +  (package
>> +    (name "bitcoin-abc")
> Since everything except ‘source’ is identical, I think we should write
> it as:
>
>    (package
>      (inherit bitcoin-core)
>      …)
>
>> +    (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
>> +    (description
>> +     "Bitcoin Cash is a digital currency that enables instant payments to anyone
>> +anywhere in the world.  It uses peer-to-peer technology to operate without
>> +central authority: managing transactions and issuing money are carried out
>> +collectively by the network.  Bitcoin ABC is the reference implementation
>> +of the Bitcoin Cash protocol.  This package provides the Bitcoin Cash command
>> +line client and a client based on Qt. This is a fork of bitcoin-core.")
> Could you make the description a bit more specific to Bitcoin ABC?
> Otherwise it’s hard to tell how it differs from bitcoin-core.

Ok, updated patch attached.
diff mbox series

Patch

From 5ecc8f90ed89f41ca1e4e1fa5372cf6da114adaf Mon Sep 17 00:00:00 2001
From: swedebugia <swedebugia@riseup.net>
Date: Thu, 1 Aug 2019 22:31:42 +0200
Subject: [PATCH] gnu: Add bitcoin-abc.

* gnu/packages/finance.scm (bitcoin-abc): New variable.
---
 gnu/packages/finance.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9b2301360..28af2c261 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1086,3 +1086,31 @@  financial years, budget estimates, bankcard management and other
 information.")
     (home-page "http://grisbi.org")
     (license license:gpl2+)))
+
+(define-public bitcoin-abc
+  (package
+    (inherit bitcoin-core)
+    (name "bitcoin-abc")
+    (version "0.19.8")
+    (source (origin
+             (method url-fetch)
+             (uri
+              (string-append "https://download.bitcoinabc.org/" version "/linux/src/bitcoin-abc-"
+                              version ".tar.gz"))
+             (sha256
+              (base32
+               "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+    (home-page "https://bitcoinabc.org/")
+    (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+    (description
+     "Bitcoin Cash brings sound money to the world, fulfilling the original
+promise of Bitcoin as Peer-to-Peer Electronic Cash.  Merchants and users are
+empowered with low fees and reliable confirmations is a digital currency that
+enables instant payments to anyone anywhere in the world.  It uses
+peer-to-peer technology to operate without central authority: managing
+transactions and issuing money are carried out collectively by the network.
+As a fork it implemented changes lowering the time between blocks and now
+offers confimations after less than 5 seconds and have significantly lower
+fees that BTC.  Bitcoin ABC is the reference implementation of the Bitcoin
+Cash protocol.  This package provides the Bitcoin Cash command line client and
+a client based on Qt. This is a fork of bitcoin-core.")))
-- 
2.19.2