diff mbox series

[bug#70703,2/2] gnu: Add rofi-pass-wayland.

Message ID 002c0ca60424a755617fc59aeb8a7a9214b369b6.1714594998.git.john.kehayias@protonmail.com
State New
Headers show
Series Update rofi-pass; add rofi-pass-wayland | expand

Commit Message

John Kehayias May 1, 2024, 8:29 p.m. UTC
This variant of rofi-pass swaps out the X-related tools used for Wayland
versions and changes the default configuration file to use them.

* gnu/packages/password-utils.scm (rofi-pass-wayland): New variable.

Change-Id: Ie844fc2f3a7f49fd6322e5418a6944b6b941abce
---
 gnu/packages/password-utils.scm | 47 +++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

--
2.41.0
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 96243a60ea..50d098ca5f 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -976,6 +976,53 @@  (define-public rofi-pass
 @end enumerate")
       (license license:gpl3))))

+(define-public rofi-pass-wayland
+  (package
+    (inherit rofi-pass)
+    (name "rofi-pass-wayland")
+    (arguments
+     (substitute-keyword-arguments (package-arguments rofi-pass)
+       ((#:phases phases)
+        #~(modify-phases #$phases
+            ;; Set the clipboard and backend tools to ones for Wayland in the
+            ;; default configuration file.
+            (add-after 'fix-etc-path 'set-wayland-defaults
+                   (lambda _
+                     (substitute* "config.example"
+                       ;; Note the typo in current configuration.
+                       (("#clibpoard_backend=xclip")
+                        "clipboard_backend=wl-clipboard")
+                       (("#backend=xdotool")
+                        "backend=wtype"))
+                     (substitute* "rofi-pass"
+                       (("/etc")
+                        (string-append #$output "/etc")))))
+            ;; Use Wayland related tools instead.
+            (replace 'wrap-path
+              (lambda* (#:key inputs #:allow-other-keys)
+                (let ((bin (string-append #$output "/bin")))
+                  (for-each
+                   (lambda (script)
+                     (wrap-program (string-append bin "/" script)
+                       (list "PATH" 'prefix
+                             (map
+                              (lambda (binary)
+                                (dirname (search-input-file
+                                          inputs
+                                          (string-append "bin/" binary))))
+                              ;; wl-copy for wl-clipboard.
+                              '("pass" "pwgen" "rofi" "wl-copy" "wtype")))))
+                   (list "addpass" "rofi-pass")))))))))
+    (inputs
+     (modify-inputs (package-inputs rofi-pass)
+       (replace "rofi" rofi-wayland)
+       (replace "xclip" wl-clipboard)
+       (replace "xdotool" wtype)
+       (delete "xset")))
+    (description (string-append
+                  (package-description rofi-pass)
+                  "\nThis package provides Wayland support by default."))))
+
 (define-public tessen
   (package
     (name "tessen")