[bug#78076,electronics-team] gnu: nvc: Update to 1.16.0.

Message ID 001e807fb12e84f56da4b8bf2ec7f0ad5dd31f3f.1745684938.git.csantosb@inventati.org
State New
Headers
Series [bug#78076,electronics-team] gnu: nvc: Update to 1.16.0. |

Commit Message

Cayetano Santos April 26, 2025, 4:28 p.m. UTC
  * gnu/packages/fpga.scm (nvc): Update to 1.16.0.

Change-Id: If781ed403cd769db85f8265fc242d0f1608d737e
---

[arguments] <#:configure-flags> Remove --enable-{vhpi,gcov}.
[native-inputs]: Add python and perl; sort.
[inputs]: Remove elfutils; sort.

Note that:

--enable-gcov is intended for debug/development of the simulator itself and should not be enabled in release builds

- VHPI is now always enabled at build time and the `--enable-vhpi` configure option has no effect.

 gnu/packages/fpga.scm | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)


base-commit: edeafb19c4a83eb81fe7e47a6a94f238db9cccf1
--
2.49.0
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index dfbe1a2894..2d3c265950 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -551,7 +551,7 @@  (define-public python-vunit
 (define-public nvc
   (package
     (name "nvc")
-    (version "1.15.2")
+    (version "1.16.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -560,12 +560,11 @@  (define-public nvc
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1r6ba5jw4ja0hv366686d8haakm57h3fl95w81hda8haq6g0dj0q"))))
+                "1hi1mqhjbj7r3wcdkjr6yazwpc7y9lqc0b8bj4ikfgdfsmakm3s4"))))
     (build-system gnu-build-system)
     (arguments
      (list #:out-of-source? #t
-           #:configure-flags #~(list "--enable-vhpi" "--enable-tcl" "--enable-gcov"
-                                     "--enable-llvm")
+           #:configure-flags #~(list "--enable-tcl" "--enable-llvm")
            #:phases #~(modify-phases %standard-phases
                         (add-after 'unpack 'clean-up
                           (lambda _
@@ -573,16 +572,17 @@  (define-public nvc
     (native-inputs
      (list automake
            autoconf
+           check ; for the tests
            flex
            gettext-minimal
            libtool
            pkg-config
-           which
-           check)) ; for the tests
+           python
+           ruby
+           which))
     (inputs
-     (list elfutils
+     (list libffi
            llvm
-           libffi
            readline
            tcl
            `(,zstd "lib")))