diff mbox series

[bug#50653] gnu: Add sdlpop.

Message ID -p2XzmyUeU34-LyC3z50Id77Y3mrwZAnC3s3bUigV4CSc1rE9Pz-FYX9HxF97dLz1oBPpUEx06AoVSLT5eJGyZRZOFmCSfXlSzKHc5U8iCc=@protonmail.com
State Accepted
Headers show
Series [bug#50653] gnu: Add sdlpop. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Sept. 18, 2021, 9:49 a.m. UTC
* gnu/packages/games.scm (sdlpop): New variable.
  [copyright]: Sort by date pkill9@runbox.com.

--
2.32.0

Comments

Xinglu Chen Sept. 20, 2021, 12:19 p.m. UTC | #1
On Sat, Sep 18 2021, phodina via Guix-patches via wrote:

> * gnu/packages/games.scm (sdlpop): New variable.
>   [copyright]: Sort by date pkill9@runbox.com.
>
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index c39770c260..0eed238f32 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -45,6 +45,7 @@
>  ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
>  ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
>  ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
> +;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
>  ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
>  ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
>  ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
> @@ -63,7 +64,7 @@
>  ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
>  ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
>  ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
> -;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
> +;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>

I don’t think sorting copyright lines is necessary.

>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -12480,6 +12481,62 @@ do so you need to explore the island, find food, build a shelter and try to
>  get attention, so you get found.")
>        (license license:cc-by4.0))))
>
> +(define-public sdlpop
> +  (package
> +    (name "sdlpop")
> +    (version "1.22")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/NagyD/SDLPoP")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "1yy5r1r0hv0xggk8qd8bwk2zy7abpv89nikq4flqgi53fc5q9xl7"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     `(#:tests? #f

What’s the reason for disabling tests?  There should a comment
explaining why.

> +       #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure)
> +         (add-before 'build 'prepare-build
> +           ;; Set correct environment for SDL.
> +           (lambda* (#:key inputs #:allow-other-keys)
> +             (setenv "CPATH"
> +                     (string-append (assoc-ref inputs "sdl")
> +                                    "/include/SDL2:"
> +                                    (or (getenv "CPATH") "")))))
> +         (add-after 'unpack 'chdir
> +           (lambda* _

Just ‘lambda’ would work.

> +             (chdir "src")))
> +         (replace 'install
> +           (lambda* (#:key outputs #:allow-other-keys)
> +             (let* ((out (assoc-ref outputs "out"))
> +                    (bin (string-append out "/bin"))
> +                    (opt (string-append out "/opt/sdlpop"))
> +                    (app (string-append out "/usr/share/applications"))
> +                    (template "src/SDLPoP.desktop.template"))
> +               (chdir "..")
> +               (install-file "prince" bin)
> +               (substitute* template (("\\$ROOT") out))
> +               (install-file template app)
> +               (rename-file (string-append app "/SDLPoP.desktop.template")
> +                            (string-append app "/SDLPoP.desktop"))
> +               (install-file "SDLPoP.ini" opt)
> +               (copy-recursively "data" (string-append bin "/data"))
> +               (copy-recursively "doc" opt)
> +               (copy-recursively "mods" opt)))))))
> +    (native-inputs `(("pkg-config" ,pkg-config)))
> +    (inputs `(("sdl" ,(sdl-union (list sdl2
> +                                       sdl2-image
> +                                       sdl2-mixer)))))
> +    (synopsis "Open-source port of Prince of Persia")
> +    (description "Open-source port of Prince of Persia, based on the disassembly
> +of the DOS version, extended with new features.")

The description should consist of one or more complete sentences, and
try to keep lines <=80 characters.

> +    (home-page "https://github.com/NagyD/SDLPoP")
> +    (license license:gpl3)))

The ‘src/GPLv3.h’ file says GPLv3 or later, so it should be
‘license:gpl3+’.

Could you send an updated patch?
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c39770c260..0eed238f32 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -45,6 +45,7 @@ 
 ;;; Copyright © 2019, 2020 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2019, 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
 ;;; Copyright © 2017, 2019 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2020 Alberto Eleuterio Flores Guerrero <barbanegra+guix@posteo.mx>
 ;;; Copyright © 2020 Naga Malleswari <nagamalli@riseup.net>
@@ -63,7 +64,7 @@ 
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
-;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12480,6 +12481,62 @@  do so you need to explore the island, find food, build a shelter and try to
 get attention, so you get found.")
       (license license:cc-by4.0))))

+(define-public sdlpop
+  (package
+    (name "sdlpop")
+    (version "1.22")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/NagyD/SDLPoP")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1yy5r1r0hv0xggk8qd8bwk2zy7abpv89nikq4flqgi53fc5q9xl7"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (add-before 'build 'prepare-build
+           ;; Set correct environment for SDL.
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "CPATH"
+                     (string-append (assoc-ref inputs "sdl")
+                                    "/include/SDL2:"
+                                    (or (getenv "CPATH") "")))))
+         (add-after 'unpack 'chdir
+           (lambda* _
+             (chdir "src")))
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (bin (string-append out "/bin"))
+                    (opt (string-append out "/opt/sdlpop"))
+                    (app (string-append out "/usr/share/applications"))
+                    (template "src/SDLPoP.desktop.template"))
+               (chdir "..")
+               (install-file "prince" bin)
+               (substitute* template (("\\$ROOT") out))
+               (install-file template app)
+               (rename-file (string-append app "/SDLPoP.desktop.template")
+                            (string-append app "/SDLPoP.desktop"))
+               (install-file "SDLPoP.ini" opt)
+               (copy-recursively "data" (string-append bin "/data"))
+               (copy-recursively "doc" opt)
+               (copy-recursively "mods" opt)))))))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("sdl" ,(sdl-union (list sdl2
+                                       sdl2-image
+                                       sdl2-mixer)))))
+    (synopsis "Open-source port of Prince of Persia")
+    (description "Open-source port of Prince of Persia, based on the disassembly
+of the DOS version, extended with new features.")
+    (home-page "https://github.com/NagyD/SDLPoP")
+    (license license:gpl3)))
+
 (define-public fheroes2
   (package
     (name "fheroes2")