diff mbox series

[bug#59758] gnu: Add dislocker.

Message ID -dgc-ZSkmwoxz2WyLij_sxULMJmgSHEdxm7zz640jRGvbi_JGjeHhQcWYr2Ys6OI7YT4NSbzwd_11Ed4DBKHDiVAihrE13ruSqFsvwN1uvs=@protonmail.com
State New
Headers show
Series [bug#59758] gnu: Add dislocker. | expand

Commit Message

phodina Jan. 9, 2023, midnight UTC
Sorry,

my mistake. That one was generated before I did git `commit --amend`.

Here's the correct one.

----
Petr

Comments

Ludovic Courtès Jan. 12, 2023, 10:33 p.m. UTC | #1
phodina <phodina@protonmail.com> skribis:

> From 0c4e34470490f4e4e1c3ee9f7239d0ce09fea81a Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Thu, 13 Jan 2022 13:24:23 +0100
> Subject: [PATCH v2] gnu: Add dislocker.
>
> * gnu/packages/linux.scm (dislocker): New variable.

Applied, thanks!
diff mbox series

Patch

From 0c4e34470490f4e4e1c3ee9f7239d0ce09fea81a Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Thu, 13 Jan 2022 13:24:23 +0100
Subject: [PATCH v2] gnu: Add dislocker.

* gnu/packages/linux.scm (dislocker): New variable.

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 568c2b6b92..072d145c23 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2198,6 +2198,30 @@  (define-public ddate
 by Robert Shea and Robert Anton Wilson.")
     (license license:public-domain)))
 
+(define-public dislocker
+  (package
+    (name "dislocker")
+    (version "0.7.3")
+    (home-page "https://github.com/Aorimn/dislocker")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1ak68s1v5dwh8y2dy5zjybmrh0pnqralmyqzis67y21m87g47h2k"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f)) ;no test suite
+    (inputs (list fuse mbedtls-apache))
+    (synopsis "FUSE driver to read/write Windows BitLocker drives")
+    (description
+     "This package provides means to to read BitLocker encrypted
+partitions.  Write functionality is also provided but check the README.")
+    (license license:gpl2+)))
+
 (define-public fbset
   (package
     (name "fbset")
-- 
2.38.1