diff mbox series

[bug#52992] gnu: Add fff.

Message ID -X2z07KXjc89x192B7wGz4x2HT22XQ9qQr7kH5bPFAJDrxkbYGKpzVsNmQwXQP-DJ9eqVaXsZwGhk5Ktwfa_KeU_NDMyiT_2gwALU5ztkRE=@protonmail.com
State New
Headers show
Series [bug#52992] gnu: Add fff. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Disseminate Dissent Jan. 3, 2022, 11:41 p.m. UTC
Disseminate,
Peace

Comments

Christopher Baines Nov. 22, 2022, 9:36 a.m. UTC | #1
Apologies for the long delay in looking at this!


This seems OK to me, I've made a few updates to the package definition,
and removed some redudant bits and pushed it to master as
bb67d7d99decd416b0235593913d23aeaddce734.

Thanks,

Chris
diff mbox series

Patch

From 749734fc412def963e590241e85428ed18c516a6 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Mon, 3 Jan 2022 18:37:55 -0500
Subject: [PATCH] gnu: Add fff.

---
 gnu/packages/disk.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 47 insertions(+)

diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index ac8b561e79..1ebc629da7 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -770,6 +771,52 @@  (define-public ranger
 automatically finding out which program to use for what file type.")
     (license license:gpl3)))
 
+(define-public fff
+  (package
+   (name "fff")
+   (version "2.2")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/dylanaraps/fff")
+                  (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "14ymdw6l6phnil0xf1frd5kgznaiwppcic0v4hb61s1zpf4wrshg"))))
+   (build-system gnu-build-system)
+   (inputs
+    `(("bash" ,bash)
+      ("coreutils" ,coreutils)
+      ("file" ,file)))
+   ;; ("xdg-utils" ,xdg-utils)))
+   (native-inputs
+    `(("pkg-config" ,pkg-config)))
+   (arguments
+    `(#:tests? #f                      ; no tests
+      #:make-flags
+      (list
+       (string-append "PREFIX="
+                      (assoc-ref %outputs "out"))
+       (string-append "CC=" ,(cc-for-target))
+       (string-append "PKG_CONFIG=" ,(pkg-config-for-target)))
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'refer-to-inputs
+          (lambda* (#:key inputs #:allow-other-keys)
+            (let ((file (assoc-ref inputs "file")))
+              (substitute* "fff"
+                (("\\bfile [-\"]" match)
+                 (string-append file "/bin/" match))))))
+        (delete 'configure))))          ; no configure script
+   (home-page "https://github.com/dylanaraps/fff")
+   (synopsis "Simple file manager written in bash")
+   (description
+    "@command{fff} (fast file-manager) is a simple, blazing fast and minimal
+file manager for Linux, written in bash.  It only requires bash and coreutils,
+and its highly optimized now for efficient performance.")
+   (license license:expat)))
+
 (define-public volume-key
   (package
     (name "volume-key")
-- 
2.34.0