[bug#75010,0/7] Roll back when deployment fails.

Message ID zrxq4axts6fcbybijcsndtuy2aw3rbjpbrcj4kaiyacimefrlz@o35c72jre4ax
Headers
Series Roll back when deployment fails. |

Message

Herman Rimm Dec. 21, 2024, 5:02 p.m. UTC
  Hello,

Felix's patch is from issue #69343, one is also squashed into [PATCH
2/7].

In [PATCH 2/7], does the mbegin above the mlet work, or is its value
discarded?  Guix deploy seems to work the same way.

In [PATCH 7/7] I try to add a test for the guix deploy rollback
behavior.  See attachment, why does this error occur?

Cheers,
Herman

Felix Lechner (1):
  Rename two remote variables confusingly named 'generations'.

Herman Rimm (6):
  monads: Add 'mmatch'.
  gnu: machine: ssh: Refactor roll-back-managed-host.
  gnu: machine: ssh: Return monadic value from roll-back-managed-host.
  gnu: machine: Remove &deploy-error.
  gnu: machine: ssh: Roll-back on failure.
  WIP: gnu: tests: Add module for guix deploy tests.

 doc/guix.texi           |   6 ++
 gnu/machine.scm         |  17 +---
 gnu/machine/ssh.scm     | 122 +++++++++++-------------
 gnu/tests/deploy.scm    | 203 ++++++++++++++++++++++++++++++++++++++++
 guix/monads.scm         |  11 +++
 guix/scripts/deploy.scm |   8 +-
 6 files changed, 279 insertions(+), 88 deletions(-)
 create mode 100644 gnu/tests/deploy.scm


base-commit: 11855e1c2863c56d9a3364cdac614a529a1c7cc2