mbox series

[bug#53008,0/3] Add plugins to Thunar

Message ID yguy23vv7c2.fsf@netpanic.org
Headers show
Series Add plugins to Thunar | expand

Message

Simon Streit Jan. 4, 2022, 3:39 p.m. UTC
Hello,

I've been trying to package some plugins for Thunar.  Unfortunately these
plugins are not loaded, or are not found in Thunar, and so far I can't see
why.  There are no errors to begin with.  A guess would be missing path
declarations from, maybe, pkg-config.  Though the libs are residing in
../lib/thunarx-3, where they should be.

I'd be very happy if someone else wants to have a look at these patches
to see if they can be made workable.


Thank you!
Simon

Comments

Ludovic Courtès Jan. 8, 2022, 10:26 p.m. UTC | #1
Hi,

Simon Streit <simon@netpanic.org> skribis:

> I've been trying to package some plugins for Thunar.  Unfortunately these
> plugins are not loaded, or are not found in Thunar, and so far I can't see
> why.  There are no errors to begin with.  A guess would be missing path
> declarations from, maybe, pkg-config.  Though the libs are residing in
> ../lib/thunarx-3, where they should be.

Can you check in Thunar itself how those plugins are searched for and
loaded?

If it’s plain ‘dlopen’, then they’ll have to be in $LD_LIBRARY_PATH.

HTH,
Ludo’.
Feng Shu March 13, 2022, 11:57 p.m. UTC | #2
I think it is controled by:  THUNARX_DIRECTORY.

```
./thunarx-provider-factory.c\0158:  dp = g_dir_open (THUNARX_DIRECTORY, 0, NULL);
./thunarx-provider-module.c\0180:  path = g_build_filename (THUNARX_DIRECTORY, type_module->name, NULL);
./Makefile\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
./Makefile.in\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
./Makefile.am\05:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
```

While THUNARX_DIRECTORY is defined in Makefile:

```
AM_CPPFLAGS = \
	-I$(top_srcdir)							\
	-DG_LOG_DOMAIN=\"thunarx\"					\
	-DTHUNARX_COMPILATION						\
	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
	$(PLATFORM_CPPFLAGS)
```

So, I think we should deal with this like xfce-panel-plugins.patch:

https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/xfce4-panel-plugins.patch
Feng Shu March 15, 2022, 1:14 a.m. UTC | #3
I do a hack in my own config like below: seem to work when install plugin in system configure :-)



```
(define-public thunar-geeguix
  (package
    (inherit thunar)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'fix-thunarx-directory
            (lambda _
              (substitute* "thunarx/Makefile.in"
                (("THUNARX_DIRECTORY=.*")
                 (string-append "THUNARX_DIRECTORY="
                                "\\\"/run/current-system/profile/lib/thunarx-3\\\" \\\n"))))))))))

```





















At 2022-03-14 07:57:13, "tumashu" <tumashu@163.com> wrote:
>I think it is controled by:  THUNARX_DIRECTORY.
>
>```
>./thunarx-provider-factory.c\0158:  dp = g_dir_open (THUNARX_DIRECTORY, 0, NULL);
>./thunarx-provider-module.c\0180:  path = g_build_filename (THUNARX_DIRECTORY, type_module->name, NULL);
>./Makefile\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>./Makefile.in\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>./Makefile.am\05:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>```
>
>While THUNARX_DIRECTORY is defined in Makefile:
>
>```
>AM_CPPFLAGS = \
>	-I$(top_srcdir)							\
>	-DG_LOG_DOMAIN=\"thunarx\"					\
>	-DTHUNARX_COMPILATION						\
>	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>	$(PLATFORM_CPPFLAGS)
>```
>
>So, I think we should deal with this like xfce-panel-plugins.patch:
>
>https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/xfce4-panel-plugins.patch
Feng Shu March 18, 2022, 6:27 a.m. UTC | #4
I have added a issue to xfce:


https://gitlab.xfce.org/xfce/thunar/-/issues/748

















At 2022-03-15 09:14:15, "tumashu" <tumashu@163.com> wrote:

I do a hack in my own config like below: seem to work when install plugin in system configure :-)



```
(define-public thunar-geeguix
  (package
    (inherit thunar)
    (arguments
     (list
      #:phases
      #~(modify-phases %standard-phases
          (add-after 'unpack 'fix-thunarx-directory
            (lambda _
              (substitute* "thunarx/Makefile.in"
                (("THUNARX_DIRECTORY=.*")
                 (string-append "THUNARX_DIRECTORY="
                                "\\\"/run/current-system/profile/lib/thunarx-3\\\" \\\n"))))))))))

```





















At 2022-03-14 07:57:13, "tumashu" <tumashu@163.com> wrote:
>I think it is controled by:  THUNARX_DIRECTORY.
>
>```
>./thunarx-provider-factory.c\0158:  dp = g_dir_open (THUNARX_DIRECTORY, 0, NULL);
>./thunarx-provider-module.c\0180:  path = g_build_filename (THUNARX_DIRECTORY, type_module->name, NULL);
>./Makefile\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>./Makefile.in\0699:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>./Makefile.am\05:	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>```
>
>While THUNARX_DIRECTORY is defined in Makefile:
>
>```
>AM_CPPFLAGS = \
>	-I$(top_srcdir)							\
>	-DG_LOG_DOMAIN=\"thunarx\"					\
>	-DTHUNARX_COMPILATION						\
>	-DTHUNARX_DIRECTORY=\"$(libdir)/thunarx-$(THUNARX_VERSION_API)\"	\
>	$(PLATFORM_CPPFLAGS)
>```
>
>So, I think we should deal with this like xfce-panel-plugins.patch:
>
>https://git.savannah.gnu.org/cgit/guix.git/tree/gnu/packages/patches/xfce4-panel-plugins.patch
宋文武 Aug. 25, 2023, 10:15 a.m. UTC | #5
Simon Streit <simon@netpanic.org> writes:

> Hello,
>
> I've been trying to package some plugins for Thunar.  Unfortunately these
> plugins are not loaded, or are not found in Thunar, and so far I can't see
> why.  There are no errors to begin with.  A guess would be missing path
> declarations from, maybe, pkg-config.  Though the libs are residing in
> ../lib/thunarx-3, where they should be.
>
> I'd be very happy if someone else wants to have a look at these patches
> to see if they can be made workable.
>
>
> Thank you!
> Simon


Hello, sorry for the delay..  I applied the thunarx-python patch now, as
other was already added, and it works!

Closing, thanks!