[bug#75051,00/14] Add loongarch64 platform support.

Message ID tencent_0B3F159D8CF29212D8DAF1CDB9D482ACAD07@qq.com
Headers
Series Add loongarch64 platform support. |

Message

Zheng Junjie Dec. 23, 2024, 5:03 p.m. UTC
  hello! This patchset add loongarch64 platform support.

use this follow command
./pre-inst-env guix pack --target=loongarch64-linux-gnu hello -R
can build, and can run on real loongarch64 machine.

./pre-inst-env guix build --target=loongarch64-linux-gnu bootstrap-tarballs
build success, but no test yet.


Zheng Junjie (14):
  guix: Add loongarch platform.
  utils: Add target-loongarch64?.
  gnu: Add linux-libre-headers-5.19.17.
  gnu: cross-base: Add cross-compiling support for loongarch64.
  gnu: %glibc-stripped: Fix cross-compiling to loongarch64.
  gnu: openssl: Support loongarch64.
  gnu: readline: Fix cross-compiling to loongarch64.
  gnu: gdbm: Fix cross-compiling to loongarch64.
  gnu: libatomic-ops: Fix cross-compiling to loongarch64.
  gnu: bash: Fix cross-compiling to loongarch64.
  gnu: sed: Fix cross-compiling to loongarch64.
  gnu: isl: Fix cross-compiling to loongarch64.
  gnu: pcre2: disable jit on loongarch64.
  gnu: elfutils: Fix cross-compiling to loongarch64.

 Makefile.am                     |  1 +
 doc/guix.texi                   |  7 +++-
 gnu/packages/base.scm           | 20 ++++++++++-
 gnu/packages/bash.scm           | 19 +++++++++-
 gnu/packages/bdw-gc.scm         | 19 ++++++++++
 gnu/packages/cross-base.scm     |  9 +++--
 gnu/packages/dbm.scm            | 19 +++++++++-
 gnu/packages/elf.scm            | 18 ++++++++--
 gnu/packages/gcc.scm            | 21 ++++++++++--
 gnu/packages/linux.scm          |  5 +++
 gnu/packages/make-bootstrap.scm |  7 ++--
 gnu/packages/pcre.scm           |  6 ++--
 gnu/packages/readline.scm       | 61 +++++++++++++++++++++------------
 gnu/packages/tls.scm            |  5 ++-
 guix/platforms/loongarch.scm    | 30 ++++++++++++++++
 guix/utils.scm                  |  5 +++
 16 files changed, 215 insertions(+), 37 deletions(-)
 create mode 100644 guix/platforms/loongarch.scm


base-commit: 3e92082463d014befdbb5073074490c07377cde3