[bug#74459,0/8] Linter improvements (eliminate false positives)

Message ID po7r7oijub2gkqzxwkgm76cprdnm3yvy4lsnwjbl4tven5zkxy@riur6kp7ldps
Headers
Series Linter improvements (eliminate false positives) |

Message

Gabriel Wicki Nov. 21, 2024, 12:40 p.m. UTC
  Hi there!

In my recent venture where i linted each and every packages' description and synopsis, I found quite a bunch of false positives.  These usually don't hurt when we lint single packages, but are quite annoying when linting all of them.  Hence I summed my findings up in some code improvements.

Have a nice week!

gabber

Gabriel Wicki (8):
  guix: lint: Fix indentation.
  guix: lint: Refine description start check logic.
  guix: lint: Allow texinfo markup at beginning of description.
  guix: lint: Allow texinfo markup at beginning of synopsis.
  guix: lint: Prevent false positives in description typo check.
  guix: lint: Ignore initials from double space check.
  guix: lint: More abbreviations.
  gnu: Move depending packages next to each other.

 gnu/packages/cpp.scm | 50 +++++++++++++++++------------------
 guix/lint.scm        | 56 +++++++++++++++++++++++++--------------
 tests/lint.scm       | 62 +++++++++++++++++++++++++++++++++++++-------
 3 files changed, 114 insertions(+), 54 deletions(-)


base-commit: 33665c52c4670bc3b4d337c89ac9cc6c4c69b26f
  

Comments

Gabriel Wicki Nov. 21, 2024, 10:25 p.m. UTC | #1
some notes:  i failed when creating the series and included a
patch that is unrelated to the changes here.  should i send in a
revision?

and did the software just swallow my cover letter?

i was btw inspired to these changes when linting all package syopses and
descriptions (issue #74329)
  
Ludovic Courtès Nov. 29, 2024, 1:55 p.m. UTC | #2
Gabriel Wicki <gabriel@erlikon.ch> skribis:

> some notes:  i failed when creating the series and included a
> patch that is unrelated to the changes here.  should i send in a
> revision?
>
> and did the software just swallow my cover letter?
>
> i was btw inspired to these changes when linting all package syopses and
> descriptions (issue #74329)

I think it went well!

Apart from the minor suggestions I sent, it LGTM.

Could you send updated patches?

Thanks,
Ludo’.
  
Gabriel Wicki Dec. 2, 2024, 10:46 p.m. UTC | #3
Thanks for your review, Ludo'!  I've addressed your concern and came up
with an even more readable solution -- I hope you agree.

Thanks for merging and have a nice week,

gabber
  
Ludovic Courtès Dec. 12, 2024, 11:07 a.m. UTC | #4
Hi,

Gabriel Wicki <gabriel@erlikon.ch> skribis:

> Thanks for your review, Ludo'!  I've addressed your concern and came up
> with an even more readable solution -- I hope you agree.

Yes, that’s nice.  Applied, thanks!

I removed “guix:” from commit subject lines and also followed up with a
commit that pre-compiles the regexp instead of recompiling it every time
via ‘string-match’ (it can make a difference when linting a large number
of packages as is the case in the Data Service for example).

Thanks!

Ludo’.