mbox series

[bug#58365,0/6] Support #:tests? in guile-build-system

Message ID e39412d9-edf3-25c7-1e86-5442ecc0a1fd@telenet.be
Headers show
Series Support #:tests? in guile-build-system | expand

Message

M Oct. 7, 2022, 8:47 p.m. UTC
Fixes: <https://issues.guix.gnu.org/58337>

guile-build-system can't guess where the tests are located, so currently 
it's opt-in, via #:test-script.  After this patch series, it is 
currently only used by guile-ffi-fftw, but other guile-build-system 
packages that use SRFI-64 could potentially use it too (e.g. 
guile-srfi-117, which is not packages or even released yet).

* First commit: package a test driver, for nicer output and for proper 
exit status.  I copied test-driver.scm to aux-files such that 
test-driver.scm can be changed without worrying about rebuilds.  OTOH, 
it isn't modified that often, so that could be left out.

Also, copying test-driver.scm causes the following:

guix build: warning: failed to load '(gnu packages aux-files test-driver)':
no code for module (gnu packages aux-files test-driver)
hint: File 
`/home/antipode/source-code/guix-master/gnu/packages/aux-files/test-driver.scm' 
should probably start with:

      (define-module (gnu packages aux-files test-driver))

Whatever code does this loading, should probably be modified to not load 
things under aux-files.

Going by "git log", the upstream of this test driver is Guix itself.

* Second commit: add support for #:tests?, using the test driver.
* Third commit: use it in guile-ffi-fftw.
* Fourth and fifth commit: cleanup of guile-ffi-fftw.
* Sixth commit: adjust guile-ac-d-bus to new 'check' phase

Only the initial commit is required for adding support for tests.

I'll leave building dependencies to <https://qa.guix.gnu.org/>.

Greetings,
Maxime.