[bug#78434,0/3] Add sqlelf

Message ID cover.1747280060.git.karl@hallsby.com
Headers
Series Add sqlelf |

Message

Karl Hallsby May 15, 2025, 3:39 a.m. UTC
  From: Raven Hallsby <karl@hallsby.com>

Sqlelf[1,2] is a tool built on top of LIEF to inspect ELF the symbols and
strings of binaries and libraries (and their transitive dependencies) using
SQL. The results of parsing the ELF files is placed in an in-memory SQLite
database that can be queried entirely within memory and can be dumped to disk
for repeated lookups.

I initially placed this program in gnu/packages/elf.scm, but that module appears
to only have low-dependency core programs. Moving the sqlelf package can be
moved to another module easily.

[1] https://arxiv.org/abs/2405.03883
[2] https://github.com/fzakaria/sqlelf

Karl Hallsby (3):
  gnu: python-lief: Update to 0.14.1
  gnu: python-sh: Update to 2.0.6
  gnu: Init sqlelf

 gnu/packages/elf.scm        | 76 +++++++++++++++++++++++++++++++++++-
 gnu/packages/python-xyz.scm | 77 ++++++++++++++++++++++++++-----------
 2 files changed, 129 insertions(+), 24 deletions(-)


base-commit: 7b73f02c38d568147f1b6a7ff4467f73a212cd1e
--
2.49.0