[bug#77110,0/2] Add UEFI firmware support in libvirt.

Message ID cover.1742368386.git.maxim.cournoyer@gmail.com
Headers
Series Add UEFI firmware support in libvirt. |

Message

Maxim Cournoyer March 19, 2025, 7:15 a.m. UTC
  Previously, our availabe UEFI firmware would not be detected by libvirt, even
when it was added to the system profile.  This change fixes that, and enables
customizing which firmwares are exposed to the QEMU backend of libvirt.

Maxim Cournoyer (2):
  gnu: ovmf-x86-64: Install QEMU firmware metadata file.
  services: libvirt: Add UEFI firmware support.

 Makefile.am                                   |   1 +
 doc/guix.texi                                 | 506 +++++-------------
 .../ovmf/51-edk2-ovmf-2m-raw-x64-nosb.json    |  36 ++
 gnu/packages/firmware.scm                     |  24 +-
 gnu/services/virtualization.scm               |  76 ++-
 gnu/tests/virtualization.scm                  |  33 +-
 6 files changed, 271 insertions(+), 405 deletions(-)
 create mode 100644 gnu/packages/aux-files/ovmf/51-edk2-ovmf-2m-raw-x64-nosb.json


base-commit: fa39695bbc0c5f79838cbca55d55eebd821a8efa