[bug#76746,00/13] Add spotify-downloader.

Message ID cover.1741114923.git.45mg.writes@gmail.com
Headers
Series Add spotify-downloader. |

Message

45mg March 4, 2025, 7:10 p.m. UTC
  If my understanding is correct, patch 4/13 will cause huge rebuilds (~4000
packages) as it changes the derivation for python-websockets to inherit from
the new python-websockets-14. I don't know how we normally handle
this. Guidance would be appreciated.

3/13 (python-rich) and 2/13 (python-rapidfuzz) will also cause a lot of
rebuilds - 637 and 147 packages, respectively (if I'm reading the `guix
refresh` output correctly). I don't have the hardware to build all of these
and see if they still work.

Hopefully we can figure this out.

45mg (13):
  gnu: python-slugify: Update to 8.0.4.
  gnu: python-rapidfuzz: Update to 3.10.1.
  gnu: python-rich: Update to 13.9.4.
  gnu: Add python-websockets-14.
  gnu: Add python-dacite.
  gnu: Add python-jaconv.
  gnu: Add python-pykakasi.
  gnu: Add python-syncedlyrics.
  gnu: Add python-soundcloud-v2.
  gnu: Add python-ytmusicapi.
  gnu: Add python-pytube.
  gnu: Add python-spotipy.
  gnu: Add spotify-downloader.

 gnu/packages/python-web.scm | 251 ++++++++++++++++++++++++++++++++++--
 gnu/packages/python-xyz.scm | 119 +++++++++++++++--
 2 files changed, 350 insertions(+), 20 deletions(-)


base-commit: f3064b765a5bbbff72bf2fd0e5fa6ecc4b1136f0
  

Comments

Sharlatan Hellseher March 9, 2025, 10:54 p.m. UTC | #1
Hi 45mg,

Thanks for the patch series.

I've started the review will report on any findings on my free time.

> If my understanding is correct, patch 4/13 will cause huge rebuilds
> (~4000 packages) as it changes the derivation for python-websockets to
> inherit from the new python-websockets-14. I don't know how we normally
> handle this. Guidance would be appreciated.

The easiest fix - use python-websockets-next@14.2 which inherits
python-websockets@13.1 and keeps all derivations away from
re-build.

Depending on the load in QA it may be detected and reported, I might
help here with.
[PATCH 03/13] gnu: python-rich: Update to 13.9.4.
[PATCH 02/13] gnu: python-rapidfuzz: Update to 3.10.1.

To ensure the build regression check after 3/13 and 2/13 I would apply
this checks:
--8<---------------cut here---------------start------------->8---
./pre-inst-env guix build -P 1 python-rich
./pre-inst-env guix build -P 1 python-rapidfuzz
--8<---------------cut here---------------end--------------->8---
that insures any dependent where packages in the first level still
build.

Or you may take a look at python-team and check if that packages are
already updated (its in the queue to be merged soon
https://issues.guix.gnu.org/75751).

--
Oleg