[bug#72925,v14,0/2] Add jpm.

Message ID cover.1736116108.git.suhail@bayesians.ca
Headers
Series Add jpm. |

Message

Suhail Singh Jan. 5, 2025, 10:28 p.m. UTC
  Hello Guix,

v14 is the same as v13, but has been rebased onto master.

Given a profile containing only jpm, bash, coreutils-minimal and
nss-certs and loading it using something like the below:

#+begin_src sh
  guix shell --pure -CPWN \
    -E '.*GTK.*|.*XDG.*|.*DISPLAY.*|TERM|INSIDE_EMACS' \
    -p /path/to/profile
#+end_src

I have tested using the below commands:

#+begin_src sh
  cd /tmp
  mkdir -p review-72925 && cd review-72925
  jpm install -l sh
  jpm install -l spork
#+end_src

For "sh", the below successfully works in janet repl which is loaded via
"jpm -l repl":

#+begin_src janet
  (import sh)
  (sh/$ touch foo.txt)
#+end_src

For spork, I the following example has been tested as working in a janet
repl invoked via "jpm -l repl":

#+begin_src janet
  (import spork/tasker)

  (def t (tasker/new-tasker))

  (ev/spawn
    (tasker/run-executors t))

  (tasker/queue-task t ["echo" "hello," "world"])
  (tasker/queue-task t ["echo" "hello," "world"])
  (tasker/queue-task t ["echo" "hello," "world"])
  (tasker/queue-task t ["sleep" "5"])
#+end_src


Omar Bassam (1):
  gnu: Add jpm package.

Suhail (1):
  gnu: Improve user-experience for jpm.

 gnu/packages/lisp.scm | 91 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 91 insertions(+)


base-commit: ddbb59f9bc5eb6dfaf1fc24881bb62f11960d664