mbox series

[bug#73842,v2,0/3] pack: Add support for AppImage pack format.

Message ID cover.1729963690.git.noelopez@free.fr
Headers show
Series pack: Add support for AppImage pack format. | expand

Message

Noé Lopez Oct. 26, 2024, 5:28 p.m. UTC
Hi Ludovic,

Thank you for the complete review, here is a new version of the patch
containing the changes you asked for. Sebastian did the news entry in
three languages (!!!) while I made the tests and git magic.

Can you explain why you want support for symlinks? I can’t think of a
use for it since AppImages are only meant to be ran through their
entrypoint, not unpacked.

A summary of changes since previous patch:

– Improved package definition for [squash]fuse-for-appimage and
  bumped versions;
– Added news entry;
– Added tests;
– Applied code suggestions from review:
  – Don’t use (use-modules) on non-toplevel;
  – Change -R warning in documentation, and ensure two spaces
    after dots;
  – Change appimage-type2-runtime synopsis and description;
  – Document and improve (concatenate-files)
  – Use better lambdas for `profile' and populating the store.
  – chmod 555 the resulting AppImage

Have a wonderful week-end,
Noé Lopez

Noé Lopez (1):
  gnu: appimage: New packages for the appimage runtime.

Sebastian Dümcke (2):
  pack: Add support for AppImage pack format.
  news: Add entry for guix pack’s AppImage format

 doc/guix.texi             |  55 +++++++++++++++-
 etc/news.scm              |  38 +++++++++++
 gnu/packages/appimage.scm | 133 ++++++++++++++++++++++++++++++++++++++
 guix/scripts/pack.scm     | 104 ++++++++++++++++++++++++++++-
 tests/pack.scm            |  41 +++++++++++-
 5 files changed, 368 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/appimage.scm


base-commit: df666602c7936f7d87354374b148ef6269844c01