mbox series

[bug#73413,0/3] Update cling to 1.1 and wrap with GCC include paths

Message ID cover.1726935737.git.maxim.cournoyer@gmail.com
Headers show
Series Update cling to 1.1 and wrap with GCC include paths | expand

Message

Maxim Cournoyer Sept. 21, 2024, 4:23 p.m. UTC
This series does two things:

1. Update the cling package and its related inputs
2. Fix cling crashing when wrong or missing GCC includes were not provided.

Cling is built to use the specific GCC version it knows from at build time;
the headers available should match that version.  Wrapping cling with the
gcc-toolchain ones ensures it works correctly out of the box, without the user
having to know to manually match the right GCC (such as in 'guix shell cling
gcc-toolchain@11').


Maxim Cournoyer (3):
  gnu: cling: Wrap with GCC include paths.
  gnu: cling: Update to 1.1.
  gnu: cling: Reduce closure by 236 MiB.

 gnu/local.mk                                  |   4 -
 gnu/packages/llvm.scm                         |  99 ++++----
 .../clang-cling-13-libc-search-path.patch     |  96 --------
 ...g-cling-13-remove-crypt-interceptors.patch | 214 ------------------
 ...g-cling-runtime-13-glibc-2.36-compat.patch |  50 ----
 .../patches/cling-use-shared-library.patch    | 107 ---------
 6 files changed, 56 insertions(+), 514 deletions(-)
 delete mode 100644 gnu/packages/patches/clang-cling-13-libc-search-path.patch
 delete mode 100644 gnu/packages/patches/clang-cling-13-remove-crypt-interceptors.patch
 delete mode 100644 gnu/packages/patches/clang-cling-runtime-13-glibc-2.36-compat.patch
 delete mode 100644 gnu/packages/patches/cling-use-shared-library.patch


base-commit: 2c54c2db410ebdda8cd71716315e4ea4d31befbd